Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 08-30-2013, 05:06 PM   #1
Junior Member
Join Date: Aug 2013
Posts: 8
Horn quit working

Ive tried turning off both 12v switches. 2005 FDDS. Taking it in to shop next week but would love to try a simple fix!

Threept5ct is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-30-2013, 07:53 PM   #2
Senior Member
Algoma's Avatar

Join Date: Nov 2007
Location: Charleston, WV
Posts: 2,166
Are you talking about the air horns? If so it is possible the solenoid has failed, a common problem.

John and Mary Knight
2015 Ventana 4311, 2015 Cadillac SRX
Algoma is offline   Reply With Quote
Old 08-30-2013, 08:40 PM   #3
Senior Member
JohnLori's Avatar
Alpine Owners Club
Join Date: May 2009
Location: Sisters, OR
Posts: 197
We had the same problem. There is another thread here from when we had our failure. We replaced the solenoid valve; it was easy. It's a silver colored cylinder under the dash. If I remember correctly, it disconnects from two lines, then simply replace with the new part. easy diy project. We got the part from Air Horns of Texas (If this is Dave, I just sent you an email)
John and Lori
2005 Alpine Coach 40FDQS
JohnLori is offline   Reply With Quote
Old 09-02-2013, 11:43 AM   #4
Senior Member
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,209
Hmmm, ok stupid suggestion, try starting the coach, letting the air pressure build up and then try it again. Once the AP has bleed off, you wont get any sound, but the clicks will still work in the wheel. I found this out when I tried to check mine parked after two weeks, it did not work, I then remember it's an "air Horn".
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:20 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.