Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-29-2010, 10:05 AM   #1
Member
 
Join Date: Dec 2009
Posts: 57
Hydro-Hot

I posted a few days ago my furnace was not working, but I have discovered my Hydro-Hot wasnt working. The 12V 25 amp fuse is blown and a replacement fuse blew as soon as it was installed. We unhooked the power wire to to the Hydro-Hot circut board and the fuse did not blow. A call to Hydro-Hot informed me that the board was bad. The part # ELE-PC4-008. Of course out of warranty and will be here Tuesday for $460 plus shipping. Has anybody else had these issues? Thanks, Doug
__________________

__________________
nssracer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-29-2010, 11:59 AM   #2
Senior Member
 
Wayne R's Avatar
 
Join Date: May 2003
Location: Winter Haven Brownsville, TX
Posts: 1,138
Check with Roger Berke at Aqua-Hot Parts - Items - Parts - RV Hydronic Heater Repair $415 and I believe free shipping still. Roger is a good tech to deal with. I had one go bad but it was not not blowing fuses. It just would shut the HH off after about 2 minutes. Luckily I had a spare from an aqua hot I cannibalized after a friend had to replace his whole unit it.
__________________

__________________
Wayne & Kathy
05 Alpine 40FDQS #75330 Towing 24' car hauler, 2012 Spyder, 2003 Harley FatBoy
Wayne R is offline   Reply With Quote
Old 01-30-2010, 10:36 AM   #3
Senior Member
 
dshogman's Avatar
 
Join Date: Aug 2004
Posts: 341
My circuit board went bad 2 years ago. There was condensation and rusting all over the back of the board. Conclusion: the original plastic drain pipe at the bottom was cracked and leaking, hence the condensation on the board. At least that's what they told me. New board, new motor also as it had stopped working. And brass fitting on the drain.
__________________
David Horn, TX; 2014 40ft Phaeton QTH; 2014 Mazda CX5; 2013 Can-AM Spyder RT-S on TandemTow trailer; Traveling with Ringo (an English Cocker)
dshogman is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydro Hot fans Spur Monaco Owner's Forum 12 12-17-2007 05:55 AM
Hydro Hot winter operation JerryKelly Newmar Owner's Forum 16 11-29-2007 04:10 AM
Hydro Hot vs. Prompt wheel opening cover dshogman Alpine Coach Owner's Forum 6 06-19-2007 02:31 AM
Hydro Hot - Must Have? or Not Worth It? Warm Heart - Cold Feet Alpine Coach Owner's Forum 19 04-13-2005 06:34 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.