Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-21-2009, 06:06 PM   #1
Senior Member
 
Wayne R's Avatar
 
Join Date: May 2003
Location: Winter Haven Brownsville, TX
Posts: 1,138
Angry Idiot Light cluster leaking air.

I started the rig up today and heard an air leak. At first I thought it was the parking brake valve with the yellow knob. Turns out it is the lower idiot light cluster. It has 2 fittings on the back of it, one has an airline going into it, most likely it is the low air pressure sensor. The other fitting is not connected. Air is leaking out of the unused fitting and 1 of the electrical sockets. I put a small amount of leak seeking silicone seal in the base of the plug sockets hoping to stop the leak.

I find 2 part numbers 104618-C and W-12684-04 RIGHT anyone know of a source for this light cluster or the manufacturer?
__________________

__________________
Wayne & Kathy
05 Alpine 40FDQS #75330 Towing 24' car hauler, 2012 Spyder, 2003 Harley FatBoy
Wayne R is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-21-2009, 07:13 PM   #2
Senior Member
 
Wayne R's Avatar
 
Join Date: May 2003
Location: Winter Haven Brownsville, TX
Posts: 1,138
I checked the tech library and found the Atica Program manual lists it as 67031 Gen1 (04) 103536 Warning module assembly (Right /bottom).
I will call them tomorrow and see if I can get a replacement. If not I will see if I can shut the message off and install an analog gauge.
__________________

__________________
Wayne & Kathy
05 Alpine 40FDQS #75330 Towing 24' car hauler, 2012 Spyder, 2003 Harley FatBoy
Wayne R is offline   Reply With Quote
Old 09-22-2009, 01:06 AM   #3
Senior Member
 
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,226
Go to the last post in this thread. OF has experience with this setup. He can help you.

Start-up Buzzers + Turn Signal Click

Good Luck.
__________________
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote
Old 09-22-2009, 11:00 AM   #4
Senior Member
 
Wayne R's Avatar
 
Join Date: May 2003
Location: Winter Haven Brownsville, TX
Posts: 1,138
While the silicone seal did not work (I did not think it would). I was able to shut the error message off by defeating the switch in the cluster. I ordered a mechanical gauge to monitor air pressure. All the other functions on this light cluster work.
__________________
Wayne & Kathy
05 Alpine 40FDQS #75330 Towing 24' car hauler, 2012 Spyder, 2003 Harley FatBoy
Wayne R is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator Air Flow Problems dgerstel Alpine Coach Owner's Forum 21 08-13-2009 10:31 AM
Let there be light (on the patio) SCVJeff Winnebago Industries Owner's Forum 6 07-06-2008 03:28 PM
Update - Failure after ACTIA Cluster Glitch Oemtech Workhorse and Chevrolet Chassis Motorhome Forum 54 04-28-2008 01:09 PM
12v Solution for Air Conditioning ChiefJohn Technology: Internet, TV, Satellite, Cell Phones, etc. 14 04-08-2007 03:16 PM
Workhorse Extreme Air Conditioning DriVer RV Industry Press 31 08-10-2006 05:25 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.