Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-26-2010, 06:36 PM   #1
Senior Member
 
Beagle RC Air's Avatar
 
Join Date: Nov 2001
Location: Raymond, Washington
Posts: 414
loss of power to dash 2005

On a 2005 with Vanesco panel our guest lost power to all dash components including cigar lighter outlets. Only light on the dash panel was the park light and buzzer. Cycling the master switch caused the engine to die. On start up everything works fine. My first thought was the relay that powers dash components but this 2005 MDDS has no relay for the dash power. An ideas?
__________________

__________________
Beagle RC Air is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-27-2010, 11:27 PM   #2
Junior Member
 
Russ Carr's Avatar
 
Join Date: Dec 2007
Location: San Martin, CA
Posts: 9
Dash power

I also had this problem with a loss of all power to the dash. Everything reset fine after I stopped and turned off all power and reset. Interesting side note, the odometer did not register for about 50 miles until I stopped but the Silver Leaf did register the miles. I finally traced the problem to the A/C-heater duct that ran in back of the dash. The metal wire in the ducting shorted across the back of one of the dash switches (don't remember which one). Moved the ducting and put tape over the switch and have not had another problem in 20,000 miles. Good luck since the problem took some time to find......look for burnt ducting.
__________________
Russ Carr is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Workhorse UFO Water Pump Blowout Loss of Power Mileage JimO Workhorse and Chevrolet Chassis Motorhome Forum 27 02-16-2010 03:53 PM
Need help with dash lights and power going out - intermittent of course siuco Monaco Owner's Forum 2 04-16-2009 07:01 AM
Loss of power in Mountains dicktater Workhorse and Chevrolet Chassis Motorhome Forum 25 09-29-2008 10:08 AM
Loss of Shore/Generator Power RVersOnline Alpine Coach Owner's Forum 6 06-26-2008 08:59 PM
Dash radio power source Gary the Wombat Winnebago Industries Owner's Forum 10 08-06-2007 07:48 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.