Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2011, 04:07 PM   #1
Junior Member
 
Join Date: Dec 2010
Location: Quakertown,PA
Posts: 22
Mini Fuses in Generator

Learned something today that may be helpful to others. Had no power to the remote and main generator switches. Found 2 mini 15amp blade fuses under a plate just above the start switch on the unit. The plate holds the radiator cap and each side has a weather proof fuse holder. Both were blown and i replaced and that was the no power issue. Onan 7.5 diesel 1999 model.
__________________

__________________
Todd & Cheryl
Quakertown,PA
1999 Alpine 36SDS
Todd49 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-26-2011, 04:57 PM   #2
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,820
Thanks.. Have a different ONAN but I'm sure it has fuses like that... Somewhere.

I think there is a contest over at the designers...

The prize goes to the engineer that puts fuse where it can NEVER be found.

Look up a song: The Designer.. You can read it

I will make it easy to find the lyrics.

The Designer
__________________

__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 03-31-2011, 08:13 AM   #3
Senior Member
 
Algoma's Avatar


 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 2,640
Todd, sounds like you don't have the generator manual. If you go to the cummins/onan website you can download the manual which has all that info in it.
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is offline   Reply With Quote
Old 04-01-2011, 02:11 AM   #4
Senior Member
 
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,226
Funny this! Today I went over to the coach to see if my genset coolant leak was a lose cap or bad connection to the cap area, which is under this little plate mentioned above. On my plate, it clearly states, coolant cap and DC fuses are located under this plate. Never noticed the little notice before, but knew the cap was under this plate. Leak was not there, guess the top sheet metal is coming off maybe tomorrow to find it. Hope I don't have to take it to cummins as last year they fixed a hose which had leaked down below on the bottom of the unit, took them a week to get the hose.
__________________
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote generator start not working, please help ShapeShifter Monaco Owner's Forum 20 08-24-2016 12:05 PM
Running the generator while on shore power? Magumba Winnebago Industries Owner's Forum 9 01-14-2010 09:03 PM
Generator only putting out a few volts AC TallPaul RV Systems & Appliances 7 12-25-2007 03:57 PM
Generator Coolant Level OldForester Alpine Coach Owner's Forum 8 10-25-2007 06:56 AM
Generator wont start (or even crank) Problem. SouthernGypsy MH-General Discussions & Problems 26 07-13-2007 09:16 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.