Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 02-28-2009, 06:53 AM   #1
Join Date: Aug 2006
Posts: 71
Our smart bed have not be functioning the last week or so. The keypads (the keypads all work) trigger the switch in the HWH control box, but no response from the pump motor. This problem showed up at the same time as our slides and jacks not working. They do work on the auxiliary pump but not the primary. I found my relay for the primary is defective and Paul with HWH get this replaced in the next few days. The smart beds do not work on either pump. They work only with the manual run toggle being held, and through the keypad or bed toggles. Paul thinks it is a Silverleaf signal issue.

Has anyone followed the wiring for the smart beds to the HWH control box? Are the smart beds wired only to the primary pump? Which pin connector into the control box?

If it is not the primary pump, would it be the circuit board in the HWH or is it a Silverleaf signal issue?


Alpine Coach, 2007 Apex MDT
Ed & Diane is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-28-2009, 01:40 PM   #2
Alpine Owners Club
Join Date: May 2007
Location: Where ever
Posts: 99

If you are an ACA member have you emailed Mark Harrah and asked him?


Paul "Sully" Sullivan

40' MD Apex
Paul "Sully" Sullivan is offline   Reply With Quote
Old 03-15-2009, 09:47 AM   #3
Join Date: Aug 2006
Posts: 71
The HWH system did deteriorate rapidly before Paul (HWH) came back out, both relays (primary and auxiliary) had failed. Paul replaced both relays. The jacks had not been retracting all the way, so he replace two sets of springs and wire brushed the other pairs. Still one jack does not want to retract completely, so Paul ordered a jack for future replacement. The relay failure was due to the likely condition that they had been in an "oil bath". We were the last coach out of the gate before the lockup at the end of last April. The HWH pan under the pumps had 1/4 to 3/8 inch of oil when we left WRV. We mopped up the excess as best as possible. It is a difficult area to clean up the oily residue from the pan, the back corners, and wiring that lays on the bottom. When home, I will look at elevating them above the bottom of the pan.

Alpine Coach, 2007 Apex MDT
Ed & Diane is offline   Reply With Quote
Old 03-15-2009, 10:31 AM   #4
RVersOnline's Avatar
Alpine Owners Club
Join Date: Apr 2006
Location: Bend, OR
Posts: 79
Send a message via Skype™ to RVersOnline
Exclamation Similar issue with non-Apex Model

We've experienced the same issue with our 34 SE, but so far it's been very "intermittent". Naturally, it won't malfunction if we take it in for service. When one of our two smart beds fails to extend or retract, the other will also not activate. And neither will the BR slide. Not sure about main slide -- but at least the BR slide and both smart beds must be on the same circuit. We presently have the coach at Carrier's for a look-see, and if we're able to find something will add to this conversation.
2007 34' FDDS Ltd SE
RVersOnline is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Smart bed bushing Lyle & Cath Alpine Coach Owner's Forum 10 12-03-2008 12:32 PM
smart bed switch mastajusty Alpine Coach Owner's Forum 1 07-21-2008 12:08 PM
Smart Bed switches big jimbo Alpine Coach Owner's Forum 17 07-01-2008 06:47 PM
Smart Bed Switches - Out - In Old Rv'er Alpine Coach Owner's Forum 10 06-11-2008 08:10 PM
Smart bed switches big jimbo Alpine Coach Owner's Forum 1 02-05-2008 03:17 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.