Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-19-2010, 08:48 AM   #1
Junior Member
 
Join Date: Jul 2010
Posts: 7
Thermovalve

There are a couple of threads about this issue but I think we've narrowed the problem down to a thermovalve in my 2004 Alpine coach. Jack Duncan is my brother in law and we have purchased this motor home together. We had a problem with the A/C. The condenser was destroyed and needed to be replaced as well as an A/C line and the dryer. Once that was completed Cummins told us the fan was not working and we checked each part in the hydraulic system and was told they were all good including the thermovalve. When Cummins put the cooling system back together they are still telling us that the fan doesnt work and the thermovalve needs to be replaced. Berendsen Fluid Power can get that valve manufactured by Dynamatic in England in 7 weeks. The two questions I have is does anyone know where we can get that thermo valve in the US Its originally an Saur-Danfoss part 553/1/09857/190. Also I've read about conversion kits from Hydraulic to I believe electric and where can I get information about the conversion kits? Thanks for your help.
__________________

__________________
Dan Green is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-19-2010, 11:21 PM   #2
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 3,925
Here is the deal--based on your brother-in-laws postings, you "thermo" wax valve is working perfectly. In 2004 and earlier models, the mechanical wax valve and engine fan were not designed to be activate by the A/C.

Look at the thread listed in your BILs postings [Dash A/C]--there is an after market option available that inserts an electric solenoid between the wax valve and the fan motor. The solenoid is then tied to an unused freon pressure sensor next to the A/C dryer in front of the firewall. These parts can be found thru sources like Grainger or by joining the Alpine Coach Assoc. and consulting our tech support advisor. You can continue looking for a new wax valve if you like but the one you have is working fine.

PM me if you want to discuss the after-market option in detail.
__________________

__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 07-19-2010, 11:57 PM   #3
Senior Member
 
Join Date: May 2004
Location: Auburn, CA, Havasu, AZ & Mulege, BCS
Posts: 5,217
I too would be suspicious of this diagnosis when they continue to fix stuff then blame the next part. Could be correct. But then again....

Don't know if you can do this w/the valve to test it, but its worth every cent you are paying for the advice:
put the valve in a pan of cold water. Put the pan on the stove w/low heat & a candy thermometer. Watch it till the valve opens & check the temp.
I do that w/new thermostats to make sure they open @ the right temp.
__________________
Baja-tested '08 2-slide 36'
Alpine: The Ultimate DIY'er Project
EngineerMike is offline   Reply With Quote
Old 07-20-2010, 10:12 AM   #4
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 3,925
EM--it appears the engine is maintaining proper cooling parameters--thus the wax valve is working correctly. The "diagnosis" is that the dash A/C does not activate the engine fan--well N-S!!!! In the early coaches, the dash A/C is not connected to the wax valve/engine fan. This would be obvious to even the most casual of observers if you crawl under the coach. The fact that his Cummins boys keep chasing the "problem" that the dash A/C is not activating the wax valve is very troubling.

The previously mentioned after market solenoid solution "developed" by WRV is an adequate workaround. I have heard that the motor fan speed might be modified by adjusting "shims" in the motor itself. This doesnt solve the problem of the wax valve design but it might explain why some early coaches have dash A/C issues and some dont. Mike Young expressed concern about total torque on the shaft that drives both the compressor and hydraulic pump so I never pursued the "shim" approach.
__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 07-20-2010, 11:02 AM   #5
Junior Member
 
Join Date: Jul 2010
Posts: 7
Old Scout
Thanks for the information. Where we are right now is that the fan is not working at all. The part we are refering to (thermovalve) is screwed into the radiator and the hydraulic lines connect to the other end of the part. When the rod inside the part heats up the lines close and the fan engages. When it cools the valves open and the fan slows down or stops. That explaination is from the hydraulic engineer. You refer to a wax valve, is that the valve that actually mounts on the fan motor? Because that valve is working and so is the fan motor. The only thing that's not working is the fan. We have left the A/C off since we dont want to overheat the unit and other than parking the unit in storage we havent driven it. Everyone we've spoken to feels that it's this thermovalve that is bad. If we clamp off the hydraulic line that closes the valve the fan works. We know where to get the thermovlave but there is a 7 week delivery from Berendsen Fluid Power. Could you also tell me more about Alpine Coach Association and how to become a member? Thanks
__________________
Dan Green is offline   Reply With Quote
Old 07-20-2010, 11:25 PM   #6
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 3,925
Yup--yr thermovalve is also called a wax valve--hot water heats the wax inside and the valve closes, activating the fan. However, until now I read this as a dash A/C issue. Is your engine actually overheating without the fan activating [assume they checked to see the engine thermostat is opening]? If so, it is the wax valve. I dont have a reliable source for the new valve. If you cant find any other source, I'll give you the name of an RV repair site in San Antonio that I think found one for me. Meaning, I cant prove it was a new valve, I am sure my old valve worked fine, so I do believe they ran up the bill on me.
__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 07-21-2010, 12:09 AM   #7
Senior Member
 
takepride's Avatar
 
Alpine Owners Club
Join Date: Aug 2007
Location: Long Beach, CA
Posts: 1,563
Dan:

See - Alpine Coach Association

And welcome!
__________________
2003 Alpine 40FDTS (400HP)
Long Beach, CA
takepride is offline   Reply With Quote
Old 07-21-2010, 07:35 AM   #8
Senior Member
 
rmmpe's Avatar
 
Join Date: May 2007
Location: Northeast PA
Posts: 1,146
Look at the "HELP !!!" post by Jack Duncan.
__________________

__________________
Bob (Squidly Down Under) & Peg - 2013 Ford Focus pushing a 2011 Phoenix Cruiser 2552S
"In God we trust" to preserve our country and bring our Troops safely home.
Carry on, regardless..................
rmmpe is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydraulic fan blasting away Stakealot MH-General Discussions & Problems 16 03-13-2009 11:47 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.