Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-24-2008, 09:59 AM   #1
Senior Member
 
Dale777's Avatar
 
Join Date: Apr 2004
Location: TX
Posts: 495
I have a 2 year old Suburban SW10DE hot water heater in my 2006 Alpine Coach.

Each time after turning on the remote switch near the kitchen sink for the SW10DE, some number of hours later, the red reset light comes on. It has done this about 5-6 times over the past couple of weeks. Each time, I turn off the switch, wait a minute, then turn it back on. Then, the red light comes on for about 15-20 seconds then goes out and everything is okay again.

Any ideas about what is wrong? Anyone have a manual for this SW10DE?
__________________

__________________
Dale & Karin
2006 Alpine Coach Limited 36FDTS
Watercolor Artist: http://www.cindydaunis.com/
Dale777 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-24-2008, 09:59 AM   #2
Senior Member
 
Dale777's Avatar
 
Join Date: Apr 2004
Location: TX
Posts: 495
I have a 2 year old Suburban SW10DE hot water heater in my 2006 Alpine Coach.

Each time after turning on the remote switch near the kitchen sink for the SW10DE, some number of hours later, the red reset light comes on. It has done this about 5-6 times over the past couple of weeks. Each time, I turn off the switch, wait a minute, then turn it back on. Then, the red light comes on for about 15-20 seconds then goes out and everything is okay again.

Any ideas about what is wrong? Anyone have a manual for this SW10DE?
__________________

__________________
Dale & Karin
2006 Alpine Coach Limited 36FDTS
Watercolor Artist: http://www.cindydaunis.com/
Dale777 is offline   Reply With Quote
Old 05-24-2008, 10:28 AM   #3
Member
 
Join Date: Apr 2006
Location: El Dorado Hills
Posts: 73
Dale, A similar situation occured on my 06 which has the same water heater. It turned out to be a bad mother board (thats what they called it). It was replaced under the water heater warranty by Guarranty. Unfortunately, I
do not have the manual.

Jerry and Toni Smith
2006 04 Limited
__________________
jerry and toni smith is offline   Reply With Quote
Old 05-24-2008, 10:44 AM   #4
Senior Member
 
Join Date: May 2004
Location: Auburn, CA, Havasu, AZ & Mulege, BCS
Posts: 5,217
Suburban may be able to answer your questions. I couldn't find a manual on their site, but they may send you one if you ask. Ask for a troubleshooting manual while you're at it, then send me a copy for the tech library.
__________________
Baja-tested '08 2-slide 36'
Alpine: The Ultimate DIY'er Project
EngineerMike is offline   Reply With Quote
Old 05-24-2008, 03:10 PM   #5
Junior Member
 
Join Date: Dec 2006
Posts: 27
Hi Dale I have the Install and Operation Manual for SW6DE Just replaced the old one in my 98FDS it was still working on gas but I didn't trust it. I have the (MODULE BD.) thats what Suburban calls it. Part # 520814. I bet its the part you need or the burner is dirty. to check that turn it on and see how lone it takes to fire up. when it starts check the flame should be blue/orange not yellow. E Mike if you need the manual I will copy it and send it to you. Hope this helps Andy
__________________
andye is offline   Reply With Quote
Old 05-24-2008, 04:28 PM   #6
Senior Member
 
Dale777's Avatar
 
Join Date: Apr 2004
Location: TX
Posts: 495
andye, emike,

Thanks for the suggestions. I found a copy of the Suburban Service Manual that covers these models:
SW3P,SW6P, SW6PE, SW6PER, SW6D, SW6DE, SW6DEM, SW10P, SW10PE, SW10PER, SW10D, SW10DE, SW10DEM.

However, I still don't know what is causing the problem that I have.

I don't know how to attach it to an irv2.com note. I've emike to give me and email address for him so that I can email it to him.
__________________
Dale & Karin
2006 Alpine Coach Limited 36FDTS
Watercolor Artist: http://www.cindydaunis.com/
Dale777 is offline   Reply With Quote
Old 05-24-2008, 04:43 PM   #7
Junior Member
 
Join Date: Dec 2006
Posts: 27
Hi Dale
If I was abt 800mi south we could try this board and see if that would fix it. It only has one plug and one spade clip to change it. In mine it is behind the water heater. good luck Andy
__________________
andye is offline   Reply With Quote
Old 05-24-2008, 05:16 PM   #8
Member
 
Join Date: Aug 2007
Posts: 94
We also have a 2006 Alpine Limited (I dislike that word - "limited"). I thought the red switch next to the sink was to enable the gas operation for the hot water heater. The electric "On / Off" switch is behind the outside water heater compartment door. Sometimes when I turn the inside switch on the red light comes on other times it does not. I have "assumed" that the light illuminating was just telling me that the gas burner had in fact lit. That heat was called for at that instant... AS Fonzie says; "am I wr-r-r-o-ong ?
__________________
2006 - 36MD Alpine

Being pushed by a 2006
C&H from NorCal is offline   Reply With Quote
Old 05-24-2008, 05:37 PM   #9
Junior Member
 
Join Date: Dec 2006
Posts: 27
Hi C&H
You are not wr-r-o-ong. The red light only stays on if the burner fails to lite Andy
__________________
andye is offline   Reply With Quote
Old 05-26-2008, 08:01 PM   #10
Senior Member
 
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,226
All,

had the similiar heater in Alpenlite 5th wheel, the light comes on when the gas burner operates, it goes out when the gas burner is not running (working is incorrect word). You can leave the electric element (if equiped) on at the same time. It will suplement the gas operation and you won't use as much, provided you have the coach plugged into shore power. Handy. We have Hydro Hot system, and hot water is lukewarm, going to dealer for fix, the heat for the coach is fine, so something is hay wire on it.
__________________
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote
Old 05-29-2008, 01:52 PM   #11
Senior Member
 
Dale777's Avatar
 
Join Date: Apr 2004
Location: TX
Posts: 495
The following is clarification of the meaning of the red RESET lamp for the gas hot water heater switch near the kitchen sink. The following is a response from Suburban tech support:

"If the red light is illuminated then the water heater has tried for ignition three times in a cycle and is now in a Lock out mode. By turning off the switch you are resetting the module board and ignition will take place.

As to service centers we have the list of our Recommended Suburban service centers if one is not in your area any local RV service center should be able to troubleshoot and diagnose a problem. If they require assistance have them contact Tech support @ 423 775-2131 extension 1.

Ronnie Ellison
Assistant Service Manager
Suburban Manufacturing Company"
__________________
Dale & Karin
2006 Alpine Coach Limited 36FDTS
Watercolor Artist: http://www.cindydaunis.com/
Dale777 is offline   Reply With Quote
Old 05-29-2008, 07:46 PM   #12
Senior Member
 
Dave Fernandez's Avatar
 
Alpine Owners Club
Join Date: Jun 2003
Location: Ontario, CA USA
Posts: 1,294
Hello Dale:

If your water heater is out of warranty and it needs a new circuit board you should check Dinosaur Electronics for a replacement boards they have a three year warranty and from what I have been told they are manufactures better than the factory boards.
__________________
Dave Fernandez
2001, 38ft FDDS, 350 ISC, Tow 2004 Yukon
http://www.alpinesocal.com
Dave Fernandez is offline   Reply With Quote
Old 07-08-2008, 06:15 AM   #13
Junior Member
 
Join Date: Jul 2008
Posts: 1
Andye do you still have the 520814 board? I am looking for one.
__________________
NE TIM is offline   Reply With Quote
Old 07-09-2008, 06:57 AM   #14
tcu
Junior Member
 
Join Date: Jun 2008
Location: Abington, PA
Posts: 8
Thanks Dale for getting everybody straigtened out on the red light for the Suburban water heater. If the red light is on the BURNER IS NOT LIT.
Thanks again.
__________________

__________________
tcu is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suburban Water Heater -- Won't Light! RobG RV Systems & Appliances 8 01-09-2009 06:58 PM
Powerline EMS - Water heater light will not light rv rick Winnebago Industries Owner's Forum 9 10-14-2008 04:20 PM
Hot Water Heater Reset Light Jim 007 MH-General Discussions & Problems 5 12-10-2005 04:27 PM
Can't Light Water Heater! Doug63 Truck Camper Discussion 7 04-14-2005 08:44 PM
Can't Light Water Heater! RV Systems & Appliances 7 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.