Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-17-2005, 04:14 PM   #1
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
How on earth do you get Support from WRV when you have a problem?

We finally picked up our MH today from Coach Care after 2 weeks because they couldn't figure out why the dash electronics are out and WRV is not providing them assistance. We and they (CC) have left messages for Rex and he doesn't return the calls. He called us last Friday and told us it was probably the "controller" and they would send CC a new one over the weekend. CC put it in and it didn't work. They tried to call WRV but could only leave messages that are not returned. They couldn't even get the correct schematics from them.

How on earth can you take your MH to a service center & WRV not show the courtesy to help them trace down the problem? Some of you have had good response from the factory - How have you done it and who - besides Rex - can you call?

The Swans
__________________

__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-17-2005, 04:14 PM   #2
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
How on earth do you get Support from WRV when you have a problem?

We finally picked up our MH today from Coach Care after 2 weeks because they couldn't figure out why the dash electronics are out and WRV is not providing them assistance. We and they (CC) have left messages for Rex and he doesn't return the calls. He called us last Friday and told us it was probably the "controller" and they would send CC a new one over the weekend. CC put it in and it didn't work. They tried to call WRV but could only leave messages that are not returned. They couldn't even get the correct schematics from them.

How on earth can you take your MH to a service center & WRV not show the courtesy to help them trace down the problem? Some of you have had good response from the factory - How have you done it and who - besides Rex - can you call?

The Swans
__________________

__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Old 08-17-2005, 05:07 PM   #3
Senior Member
 
Join Date: Jun 2005
Location: Abington, PA
Posts: 1,103
Swans, I am not familiar with Rex, but Mike Glazier is the gentlemen you want to speak to. I think Rex may be the company mascot(bull terrier or something).
Ted
__________________
Ted & Carol Ulmer
2005 Alpine 34', 34FDDS
2006 PT Turbo pusher
Ted III is offline   Reply With Quote
Old 08-17-2005, 05:31 PM   #4
Senior Member
 
Cedar41's Avatar
 
Join Date: Sep 2004
Location: Cedar Creek Lake, Texas
Posts: 238
REX is not the person you want to talk to. The first warranty call we had (many) about an AC problem he told us he had never really been in a Motor Home before.

Do not talk to him!!!!!!! Ask for Leslie. Email Mike, the service manager. He will get the job done. mglazier @wrv.com
__________________
38ft, 2004, Diesel
Cedar41 is offline   Reply With Quote
Old 08-17-2005, 05:50 PM   #5
Senior Member
 
Cedar41's Avatar
 
Join Date: Sep 2004
Location: Cedar Creek Lake, Texas
Posts: 238
I think REX must be married to the owners daughter
__________________
38ft, 2004, Diesel
Cedar41 is offline   Reply With Quote
Old 08-17-2005, 07:47 PM   #6
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
Thank you for each of your inputs! Rex is/was a real live person who initially sounded as though he was going to be real helpful and make things happen! But it was a DUD!

I have sent an email to Mike Glazier and will follow it up with a phone call tomorrow. I try to have as little contact with the factory as possible after less than satisfactory experiences over 2 years - and figure most things out for myself - but I am stumped on this one!

Thanks again, Ted and John for taking the time to respond! The Swans
__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Old 08-18-2005, 04:41 AM   #7
Senior Member
 
Join Date: Jun 2005
Location: Abington, PA
Posts: 1,103
swansnest, stay right on WRV and Mike Glazier & Leslie for help. It will help you and it will help all of us get though to these people that they have a serious quality control problem.
Thank you,
Ted
__________________
Ted & Carol Ulmer
2005 Alpine 34', 34FDDS
2006 PT Turbo pusher
Ted III is offline   Reply With Quote
Old 08-18-2005, 09:18 AM   #8
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
Well, we got a phone call this morning at 7:30 from Rex and then an email back from Mike. They really started hopping around. After apologizes for "the communication breakdowns" - they said that the schematics are "proprietary" (service people have no right to see them) and they promised to work with Coach Care if we took the coach back. We have now been "turned over" to Mark who is suppose to have the expertise to fix it. He called and said he had already spoken to CC and promised to keep us in the loop.

Coach Care said it takes the "Owners" to really hit them to get things done. Only problem was we kept hitting a brick wall, too. We will take it back in next Wed and see what happens. We will post what the solution was when they find it. Thanks John and Ted for yur help!
The Swans
__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Old 08-18-2005, 11:35 AM   #9
Senior Member
 
Mike & Nancy's Avatar
 
Join Date: Jan 2005
Location: Beaumont, CA
Posts: 222
Swansnest

I have dealt with Mark and have had a very positive response from him on several occasions. He is quite busy....so sometimes it takes awhile for him to get back with you. His phone number is 866-567-4133 X264. Good luck and hopefully will see you at a Alpine SoCal Rally....great people and lots of fun.

Mike
__________________
Mike and Nancy
2015 Newmar Dutch Star 4018
2009 Hummer H3 Alpha
Mike & Nancy is offline   Reply With Quote
Old 08-18-2005, 11:59 AM   #10
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
Thanks, Mike! We have heard from Mark twice already - trying to figure out what the problem is. He seems really nice. In fact, when you talk to the guys on the phone,<span class="ev_code_BLUE">they all seem like real nice guys</span>! But it just seems like PR because they haven't followed through. Hope this time will be different!

We won't be at the SoCal Rally as we will be on a tour in the North/East - Mid/West. We will be at Homecoming in Oct. though.

The Swans
__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Old 09-08-2005, 02:44 PM   #11
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
Well, it has now been about 7 weeks since our Dash Instruments (Gauges) went out.

After Coach Care Irvine had it for 2 weeks and couldn't figure out what was wrong with it - It spontaneously popped back on when we were almost to San Diego 3 weeks ago. We had driven 700 miles that had not registered on the odometer.

The panel stayed on until we took it to Cummins the next week to have the Injector Pump worked on. When we went to get it the Panel was OUT again - as well as the Back up Monitor. I

n the meantime Mark had sent us the wiring diagram just in case it went out again while we were on the road. We took it from Cummins to the Paint Department in Chino to get the 3M Film applied to the front and left it there.

Mark is out of the "office" until next week and we are going out of town for 10 days. Hopefully, when we return and get the Coach - Mark can walk Tris through "trouble-shooting" the problem before we leave for "Homecoming". When we finally find out what the problem is - we will post it here - in case anyone else has a similar problem with their instrument panel.

The Swans
__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Old 09-11-2005, 08:53 AM   #12
Junior Member
 
Join Date: Nov 2003
Posts: 4
I have a 2004 Alpine 36 MD and had trouble with the dash air. Finally had to take it to Freightliner to have it fixed. It is my understanding that the dash controls etc. are from Freightliner!! You might make a call to them and see if they can help. I had to pay Freightliner for the repair and was reimbursed by WRV
Larry
__________________
Lar58 is offline   Reply With Quote
Old 09-11-2005, 02:25 PM   #13
Senior Member
 
swansnest's Avatar
 
Alpine Owners Club
Join Date: Aug 2005
Location: North Tustin, CA
Posts: 320
Larry - Thanks for the reply but our problem isn't with the dash air conditioning. All of our gauges are off - No everything - fuel - rpms, odometer, speedometer, turn signals - We drove 700 miles w/o it being registered on the odometer. (We had trouble with the dash air when we got it new but WRV fixed it in Yakima.)
We are still trying to figure out what the problem is!
__________________
The Swans
2007 ALPINE APEX 40'MDTS
#75710.
swansnest is offline   Reply With Quote
Old 09-12-2005, 03:38 PM   #14
Senior Member
 
Join Date: Aug 2005
Posts: 183
I don't know if this is at all helpful, but our current rig is Cummins and all the instruments run through the speedometer, I had mine replaced because of instruments spontainiously going out and sometimes coming back on. The new speedo works great and we have had no more guage problems.

Anxiously awaiting our APEX.
__________________

__________________
Lyle & Cathy Fuller
06 Apex 40FDQS
Datastorm #3481
Lyle & Cath is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WH Tech Support Phone Number Rocky 2 Workhorse and Chevrolet Chassis Motorhome Forum 3 05-23-2008 05:56 PM
WRV Announces New Director of Customer Services DriVer RV Industry Press 3 02-06-2008 07:59 PM
Monaco Tech support nutensteve Monaco Owner's Forum 15 01-19-2008 05:02 PM
Monaco 24/7 Tech Support Hotline ronboc Monaco Owner's Forum 9 06-06-2007 05:49 PM
Dear Tech Support jeeprubi RV'ing Humor & Crazy but True Stories 2 03-31-2007 09:49 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.