Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 03-21-2011, 12:41 AM   #1
Join Date: Dec 2008
Location: Fulltimer
Posts: 30
Unhappy xantrex or ???

While dry camping ( no shore power or generator ) the 110 in Apex goes from 110 to 0, making a clicking sound as refrigerator goes off and on. Sometimes lasts 10 minutes other times lasts 1hour, then everything seems okay till genstart starts generator a couple of hours later. Im baffled, just had 3000 xantrex checked out a month ago and batteries show adequade charge. Would appreciate any advice.

Christopher Cratch is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-21-2011, 10:19 AM   #2
Senior Member
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 21,173
It does sound like the inverter is cutting out.. This may be caused by any of the following:

Low battery, as the unit sucks power the voltage drops to the cut off point.

Cables too small (12 volt side) again as it sucks current the voltage drop increases so the inverter sees it as low-volt

Bad connection (high resistance) even a fraciton of an ohm is significant at 100 amps,

Bad inverter... but you had it checked out.

Suggestion: Monitor the voltage on the 12 volt side of things in two places while this is happening.

1: Battery terminals
2: Inverter terminals

NOTE.. My PRosine does 2 for me

Finally.. I don't know what inverter you have but the Prosine, also by Xantrex has a very nice remote display and a computer with memory.

Including "Last 20 error messages" or something like that.. I can go into the set up menu and ask it what the bleep is going on.

World's dirtiest word: BLEEP.. Why? Because you use it to replace all the other dirty words.

Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 03-23-2011, 11:40 AM   #3
Senior Member
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,209
Chris try shutting off all the master switches for 5 minutes, then turning them back on. Sometimes ours does the same thing, my remedy is the above. The Xantrex gets a wild hair in its brain once in a while, and it needs to be shut off. You can also hit the RED reset button, but the above should work. Problem give me a call and we can discuss it.
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote
Old 03-23-2011, 12:32 PM   #4
Senior Member
Join Date: Nov 2005
Posts: 2,807
Clarification--the inverter is not routed thru the "master" switch [unless its an APEX thing]. Only sure way to totally de-energize the inverter is to disconnect cable from bats. Reset switch on inverter or "factory default" setting on control board menu will reset 90-95% of inverter components.
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 03-23-2011, 03:24 PM   #5
Senior Member
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,209
It might be an APEX thing, since, when I turn my master switches off, the inverter goes dark, provided the "inverter is not enabled"(read inverting or pass through). As I understand it, there is some kind of direct feed to it from the batteries, but like I said it goes dark when the master switches are off.
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xantrex 2000W Inverter/Charger only charging at 13.3v? David Bott RV Systems & Appliances 23 01-30-2011 06:52 PM
Xantrex recall mythplaced RV Systems & Appliances 5 11-06-2010 08:57 AM
Xantrex chris cratch Alpine Coach Owner's Forum 14 09-07-2009 07:17 PM
Is your Xantrex Inverter/charger ever erratic? dgerstel Alpine Coach Owner's Forum 3 09-18-2007 04:47 AM
Xantrex Customer Service afrank1971 Winnebago Industries Owner's Forum 6 08-30-2007 02:50 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:21 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.