Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-13-2008, 08:13 PM   #1
Senior Member
 
Lindenberg's Avatar
 
Join Date: Aug 2006
Posts: 281
I have a Xantrex Freedom Combi inverter/charger that has a problem I can't figure out. When AC is supplied to the Xantrex, the batteries will charge, the inverter on indicator lights up but the inverter won't power any of the outlets. If I turn off the AC power to the unit, the inverter will power all the outlets from the batteies. Any ideas what is causing this?
__________________

__________________
Tom & Laurel

2000 Alpine Coach Limited 36FDS
Lindenberg is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-13-2008, 08:13 PM   #2
Senior Member
 
Lindenberg's Avatar
 
Join Date: Aug 2006
Posts: 281
I have a Xantrex Freedom Combi inverter/charger that has a problem I can't figure out. When AC is supplied to the Xantrex, the batteries will charge, the inverter on indicator lights up but the inverter won't power any of the outlets. If I turn off the AC power to the unit, the inverter will power all the outlets from the batteies. Any ideas what is causing this?
__________________

__________________
Tom & Laurel

2000 Alpine Coach Limited 36FDS
Lindenberg is offline   Reply With Quote
Old 08-13-2008, 08:41 PM   #3
Senior Member
 
Alpine Owners Club
Join Date: Dec 2001
Location: Las Vegas, NV
Posts: 1,100
Tom,

When AC is supplied to the Xantrex the inverter never runs, only the charger. At that time AC power is run through the Xantrex's internal transfer switch. Since the charger will work, then the AC into the Xantrex is OK and since the inverter will work, then the output wiring must be OK. The only thing I know of, would be a problem with the internal transfer switch. There could be some other issue, but I no longer have the manuals on your unit. What are the other LED's doing?
__________________
Dale Gerstel
AMG GTS
Las Vegas, NV
Had: 2007 Limited SE 40fdts
dgerstel is offline   Reply With Quote
Old 08-13-2008, 08:46 PM   #4
Member
 
work2play's Avatar
 
Alpine Owners Club
Join Date: May 2005
Location: Moorpark, CA
Posts: 99
my coach had similar problems as yours a few months back. it was found that the hot line that was coming from the inverter to the breaker panel had come loose. once this was tightened everything worked fine.
__________________
2003 Alpine Coach 34 FDDS

Moorpark, CA
work2play is offline   Reply With Quote
Old 08-14-2008, 06:20 AM   #5
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 3,938
You might check the fuse (push-set type} on the inverter but yr best bet is to check the 120v connections on both the inverter and the breaker panel--besure all shore and inverter power is off. Fact is these coaches bounce down the road mile after mile so unlike your home electrical systems, we need to check/tighten all the 120v and 12v connections [set screw-yype] periodically.
__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 08-14-2008, 08:47 PM   #6
Senior Member
 
Alpine Owners Club
Join Date: May 2008
Location: Vancouver, WA
Posts: 2,226
Do a search on this forum for generator problems, transfer switch problems and inverter problems. You will find massive amounts of information on those systems and the root cause for most of the problems. It was/is very, very, very poor wiring quality control at WRV. This is especially true regarding the generator, transfer/surge guard/inverter and any 110V wiring in the coach. It's an interesting read, take your tranquilizer first, because when you finish, you will be mad as heck. RVIA my backside!!!!!!!
__________________

__________________
Monty & Janet - 2007 Alpine APEX 40 MDTS
S/N - 75715 - Retired - Master Certified RV Tech
Old Rv'er is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xantrex freedom 458 invertor problem cuuckey MH-General Discussions & Problems 4 12-09-2008 12:08 AM
Problem Getting connected Latitude Forum 101 | Announcements | Member Concerns 8 11-18-2008 01:01 PM
xantrex auto gen start problem Techie RV Systems & Appliances 3 09-15-2008 07:54 AM
120v Electrical Outlets not working in 03 MDDS rbguinn Alpine Coach Owner's Forum 8 09-11-2008 07:35 PM
Lack of 120v outlets Navy Flier Winnebago Industries Owner's Forum 10 02-18-2008 06:09 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.