RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-02-2012, 04:44 PM   #1
Senior Member
 
redboots's Avatar
 
Join Date: Oct 2008
Location: Kanab, Utah
Posts: 101
Electric Mirrors

I haven't been on here in a long time because I haven't had a problems. Whoopie! Now I do. My electric mirrors quit working. I have an '09 Surf Side 29A. I have the owners manual for the mirrors. I have determined that there is no power to the mirror switch or the heater switch which are tied together. It's supposed to have a 1.5 amp fuse in the mirror harness, but the wires from the switches disappear into a factory harness that is labeled (38128). I have checked every single fuse and none of them are blown and I can't find the 1.5 amp fuse. Does anybody have any ideas where National picked up the power supply to these mirrors? I'm thinking since the feed to the mirrors comes right out of a factory harness it's got to be fused somewhere, but all the fuses look good and everything else works fine. Any help or thoughts would be appreciated.
__________________

__________________
Jim & Bonnie Vann

Red Boots Ranch
redboots is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-02-2012, 06:45 PM   #2
Senior Member
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Oct 2004
Location: Scottsdale, AZ
Posts: 1,468
If the mirrors originally worked but with ignition switch on as in my coach, look for a NRV added fuse panel under/in the dash that supplies power to coach builder added hard ware such as the mirrors, radios ,etc..

Marty
__________________

__________________
2003 34' Dolphin 5342, W22, UP, UPGBrake, F and R Track Bars, Rear IPD sway bar, Koni FSDs, Safe-T-Plus, Scan Gauge II.. 2004 Jeep Liberty, Blue-Ox Adventa..
M&EM is offline   Reply With Quote
Old 07-02-2012, 07:08 PM   #3
Senior Member
 
redboots's Avatar
 
Join Date: Oct 2008
Location: Kanab, Utah
Posts: 101
Thanks, I'll try that in the morning. I checked every fuse under the dash for "body builder" add ons, same on the core support. Any fuses remotely associated with 'body' got checked and looked okay. If I could find the power source for the harness, I could back track it to the switch I think.
__________________
Jim & Bonnie Vann

Red Boots Ranch
redboots is offline   Reply With Quote
Old 07-03-2012, 01:06 PM   #4
Senior Member
 
redboots's Avatar
 
Join Date: Oct 2008
Location: Kanab, Utah
Posts: 101
Many thanks to M&EM, problem solved. Only on an RV do you run into this stuff. The green/yellow tracer wire from the mirror switch (power) is connected to a light green wire that is part of harness #(38138). That green wire goes to a 4 way plug, then another 4 way plug, then a 6 way plug. On the opposite pin position to where the light green wire goes in, a bright green wire comes out of the plug and goes directly to an accessory fuse panel (just like E&EM said). At that fuse location, there was NO fuse installed. Interesting? Except a while back I remember finding a 15A fuse laying on the floor mat. I thought is was just a stray from somewhere because fuses just don't fall out, right? Well that's exactly what happened. I installed a new 15A fuse and the mirrors have power! Like I said, only in an RV. Have you ever seen a fuse fall out of anything else?
__________________
Jim & Bonnie Vann

Red Boots Ranch
redboots is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.