RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-16-2007, 04:14 AM   #1
Member
 
JKCTAZ's Avatar
 
Join Date: May 2007
Location: Cave Creek, AZ
Posts: 42
can't find the fuses. Went camping a couple weeks ago and blew the fuse (somehow?) for the power visors/map lights/radio. I looked under the "hood" and found the chassis fuse box and sure enough one of the big 30A aux fuses was blown. Replaced it, but still nothing. Checked the house panel by the bathroom and everything was good, none were labeled so as to make me think they would cover dash components.

Is there a sub-panel off that chassis panel for dash type components? Real puzzler is the light on the radio switch comes on, but no power to the radio itself.

2004 Dolphin LX, W22,

Thanks,
__________________

__________________
Jeff, Kristi, Conner, Trevor and a yellow lab that is always smiling
'04 Dolphin LX, W22
JKCTAZ is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-16-2007, 04:14 AM   #2
Member
 
JKCTAZ's Avatar
 
Join Date: May 2007
Location: Cave Creek, AZ
Posts: 42
can't find the fuses. Went camping a couple weeks ago and blew the fuse (somehow?) for the power visors/map lights/radio. I looked under the "hood" and found the chassis fuse box and sure enough one of the big 30A aux fuses was blown. Replaced it, but still nothing. Checked the house panel by the bathroom and everything was good, none were labeled so as to make me think they would cover dash components.

Is there a sub-panel off that chassis panel for dash type components? Real puzzler is the light on the radio switch comes on, but no power to the radio itself.

2004 Dolphin LX, W22,

Thanks,
__________________

__________________
Jeff, Kristi, Conner, Trevor and a yellow lab that is always smiling
'04 Dolphin LX, W22
JKCTAZ is offline   Reply With Quote
Old 09-16-2007, 05:19 AM   #3
Senior Member
 
Richard S.'s Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: May 2007
Location: El Cajon CA
Posts: 1,833
Do you have an access panel on the top of you dash board. If so you may find a fuse block under it. The access panel is held on with tabs on one side and velcro on the other.
Good Luck
__________________
2007 Sea Breeze LX 8321 Ford Chassis
2004 Ford Ranger Edge
El Cajon CA.
Richard S. is offline   Reply With Quote
Old 09-16-2007, 06:52 AM   #4
Senior Member
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Oct 2004
Location: Scottsdale, AZ
Posts: 1,481
Look under dash in area near foot park brake. mine has a coach added fuse panel there for some option that NRV ads
__________________
2003 34' Dolphin 5342, W22, UP, UPGBrake, F and R Track Bars, Rear IPD sway bar, Koni FSDs, Safe-T-Plus, Scan Gauge II.. 2004 Jeep Liberty, Blue-Ox Adventa..
M&EM is offline   Reply With Quote
Old 09-17-2007, 03:34 AM   #5
Senior Member
 
Workhorse Chassis Owner
Join Date: Sep 2007
Location: st.charles mo.
Posts: 1,444
My 2005 dalpin did the same thing. fuse is under the small panel on top of the dash. Replaced the fuse. No problem sence. Good luck.
speed racer is offline   Reply With Quote
Old 09-17-2007, 09:03 AM   #6
Senior Member
 
Join Date: Oct 2005
Posts: 1,213
I have a 2000 Tradewinds.There are a bunch of fuses behind the panel on the left of the captains chair under the window.
BOB
bldrbob is offline   Reply With Quote
Old 09-17-2007, 07:00 PM   #7
Member
 
JKCTAZ's Avatar
 
Join Date: May 2007
Location: Cave Creek, AZ
Posts: 42
thanks everyone. I'll look at both options this weekend. There is a panel on top in front of the driver, never tried to open it. I'll look under dash also. Must be a sub panel of the main fuse block in the engine compartment.
__________________
Jeff, Kristi, Conner, Trevor and a yellow lab that is always smiling
'04 Dolphin LX, W22
JKCTAZ is offline   Reply With Quote
Old 09-25-2007, 04:00 AM   #8
Member
 
JKCTAZ's Avatar
 
Join Date: May 2007
Location: Cave Creek, AZ
Posts: 42
Aha! My wife asked what the cut out door on top of the dash was. I told her, in my best official voice, "an airbag, driver only". While she stewed about that I figured I could find out what it really is. Opened it up this weekend, replace the fuse, and everything works fine. Now to find the parasitic drain on my batteries and I'd be set.

Thanks again for the help.
__________________
Jeff, Kristi, Conner, Trevor and a yellow lab that is always smiling
'04 Dolphin LX, W22
JKCTAZ is offline   Reply With Quote
Old 09-25-2007, 04:32 AM   #9
Senior Member
 
Richard S.'s Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: May 2007
Location: El Cajon CA
Posts: 1,833
When you find the Bat. drain, be sure to let us know what it is.
__________________
2007 Sea Breeze LX 8321 Ford Chassis
2004 Ford Ranger Edge
El Cajon CA.
Richard S. is offline   Reply With Quote
Old 09-26-2007, 06:07 PM   #10
Member
 
JKCTAZ's Avatar
 
Join Date: May 2007
Location: Cave Creek, AZ
Posts: 42
not found, but a couple thoughts so far.

Chassis battery may be overcharging. With the engine running my battery was boiling. Three of the six cells are dead on a two month old battery, which also supports this. In my 'spare time' I will wire a resistor in line (don't want to blow my meter) and try to measure the amperage and voltage going into it from the alternator. May be a bad diode on top of alternator. It may have this problem with just the generator running too. If it is related to inverter I am out of my league.

House batteries are draining too. Used a screwdriver to get rid of CO and propane monitor/alarms. When I hit the disconnect switch and then pulled the positive cable I got resistance to ground. This means some circuit is open even though the disconnect switch was thrown. When reconnecting the wire I got a spark, a sure sign of something being on (and drawing current) when it should not be. This might be a bit harder to track down given the myriad house systems, motors, etc. I also see no sign that the tiny solar panel on the roof is doing anything.

What happened to a good old U-joint failing, or brake pad squealing. Need to find a good motorhome electrician in Phoenix. They scare me when I know more about circuits than the 'expert'.
__________________
Jeff, Kristi, Conner, Trevor and a yellow lab that is always smiling
'04 Dolphin LX, W22
JKCTAZ is offline   Reply With Quote
Old 09-27-2007, 04:46 PM   #11
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 29,645
Drains, ECM,TCM,RADIO,TV's, CONTROL BOARDS for REFER,FURNACE,HWH etc etc.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-03-2007, 08:08 AM   #12
Senior Member
 
Workhorse Chassis Owner
Join Date: Sep 2007
Location: st.charles mo.
Posts: 1,444
Does your mh have a small solar panel on the roof. If so it is a solar carger for the house batts.and will cause a spark like you discribed. If it is working it will spark because it charges all the time. if it is'nt it can spark because it is shorted. Had to replace mine thie summer for that reason. Got mine on the internet its a gopower 10watt solar charger. I shoped around and got mine for 106$ including shiping. GOOD LUCK!
speed racer is offline   Reply With Quote
Old 10-03-2007, 06:45 PM   #13
Member
 
JKCTAZ's Avatar
 
Join Date: May 2007
Location: Cave Creek, AZ
Posts: 42
yes. good catch, didn't think of that. I thought when the disconnect switch was thrown this would also cut out. I'll check it further.

Thanks,
__________________
Jeff, Kristi, Conner, Trevor and a yellow lab that is always smiling
'04 Dolphin LX, W22
JKCTAZ is offline   Reply With Quote
Old 05-29-2009, 06:39 PM   #14
Junior Member
 
Join Date: May 2009
Posts: 12
Quote:
Originally Posted by JKCTAZ View Post
Aha! My wife asked what the cut out door on top of the dash was. I told her, in my best official voice, "an airbag, driver only". While she stewed about that I figured I could find out what it really is. Opened it up this weekend, replace the fuse, and everything works fine. Now to find the parasitic drain on my batteries and I'd be set.

Thanks again for the help.
Thanks so much for your problem, because we had the same problem, except we were in our driveway and could not leave on our trip because we could not find the fuse panel, my husband also in his authoritative voice said, that panel is there so they can work on the dash!. well after finding this great website and seeing your issue, so I looked like a hero when I went back outside and said" this is here so they can work on the dash huh!" and opened it up and said there you go , your fuse panel.
It was a good laugh and what a relief! Missed our trip though due to other circumstances, but at least we know where to go for information.
So glad to see that everyone out there has the same issues with National, there owners manual leaves alot to be desired.
__________________

JLCHERITAGE is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV Fuses '04 Dolphin Mike_Chicago National RV Owner's Forum 11 12-16-2013 12:01 PM
Fuses ready2rv Newmar Owner's Forum 1 02-13-2009 01:56 PM
Fuses Tom & Dee Workhorse and Chevrolet Chassis Motorhome Forum 8 03-04-2007 12:16 PM
Fuses hrhuggie Alpine Coach Owner's Forum 8 11-15-2006 06:33 PM
Where are the fuses? kymacs Newmar Owner's Forum 9 10-31-2005 05:22 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.