RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-09-2014, 01:06 AM   #1
Senior Member


 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,120
Generac 7.5KW gennie problems

I'm looking for anyone with a National rig,like my 7390 LTC, with the front loaded 7.5. Have you had problems starting it? Mine just wants to turn over slowly and then shut down after the 15 seconds. A couple of times the red light didn't turn off after turning the switch off while trying to start it and the clock kept running. It finaly stopped after awhile. I'm wondering if it might be a switch? But then it can't be that simple.
It does get run once a month,when I can start it and now has a loose belt,at least I hope it' a loose belt.I need to know how to get in to it to tighten it.
It's s'posed to have a slide,but it sure doesn't look like it and how do you work on it w/o one?
__________________

__________________
BIGDOG
'01 Tradewinds 7390 LTC
2011 Jeep Liberty
bigdog is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-09-2014, 07:32 PM   #2
Senior Member
 
Rexhall Owners Group
Join Date: Jul 2008
Posts: 134
While I don't have a National coach, based on what you have described, I would guess the batteries are down on charge so the starter can't spin the motor fast enough to get it to start.
__________________

JohnInAz is offline   Reply With Quote
Old 04-12-2014, 12:35 AM   #3
Senior Member


 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,120
Took it in to have the batteries checked and the tech says that he can't test them because at least one of them,#2 in the series,is boiling and I think the #1 is also. I can understand that they are being overcharged,but I supposidly have a smart charger and it isn't working to smartly,I guess. Man,nothing wants to work right.
__________________
BIGDOG
'01 Tradewinds 7390 LTC
2011 Jeep Liberty
bigdog is offline   Reply With Quote
Old 04-25-2014, 07:51 PM   #4
Junior Member
 
Join Date: Jul 2011
Posts: 9
I have a '99 National RV with the same Generac Generator. My red light came on and the Hr meter was clicking like it was running but it wasn't. I found out the the 3rd screw on the right side of the board came loose. Tightened it up and everything was fine again.
rlgjlg is offline   Reply With Quote
Old 04-28-2014, 11:48 AM   #5
Senior Member


 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,120
Do you mean on the control board on the gennie itself or someplace else?
__________________
BIGDOG
'01 Tradewinds 7390 LTC
2011 Jeep Liberty
bigdog is offline   Reply With Quote
Old 04-28-2014, 03:00 PM   #6
Member
 
twn454's Avatar
 
National RV Owners Club
Join Date: Sep 2013
Posts: 45
National used Generac as well as Onan?
__________________

__________________
Rick & Tonja
2001 National Tradewinds 7390, Cat 3126B, Allison 6speed
Toads-FLTR3SE CVO, T-Rex, S55 AMG
twn454 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dealers for Palazzo Problems & Thor Slide Problems "007" Thor Industries Owner's Forum 29 11-10-2015 06:29 AM
Generac 75D starting problems bigdog RV Systems & Appliances 0 04-08-2014 11:36 PM
Garmin 760 dezl lmt problems THERAPY GUY Newmar Owner's Forum 2 03-03-2014 01:03 PM
EGR soot cleaning to have less replacement problems tom chelbana Cummins Engines 2 02-14-2014 09:09 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.