RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2010, 08:49 AM   #1
Junior Member
 
Join Date: Jun 2010
Posts: 4
generator runs but no 120v power

Hi,

I've a Onan Emerald III GenSet in a '99 Sea Breeze that runs but does not deliver power to the coach.

Shore power works well. 12v battery power works well.

The generator had been surging on occasion - not all the time, but once in a while - sometimes upon starting, sometimes after 15 or 20 minutes. (I keep the tank pretty full so it's not a gas tank issue).

Last night it surged for a while and then stopped. I started it back up and that's when I noticed the lack of 120v power.

I was going to see if the 150 amp circuit breaker was tripped but coudn't locate the the reset lever. (any ideas there, too?)

What should I check regarding the generator and the electrical system, or should I just call the repair shop?
__________________

BrianV is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-29-2010, 09:40 AM   #2
Senior Member
 
Richard S.'s Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: May 2007
Location: El Cajon CA
Posts: 1,826
Check the breaker on the generator. Turn them off and on a couple of times.
__________________

__________________
2007 Sea Breeze LX 8321 Ford Chassis
2004 Ford Ranger Edge
El Cajon CA.
Richard S. is offline   Reply With Quote
Old 06-29-2010, 10:37 AM   #3
Senior Member
 
johnandcaren's Avatar
 
Workhorse Chassis Owner
Join Date: Feb 2010
Posts: 121
Idea!

Brian,
I am in no way a qualified gen person, however I had the same problem on a home still under the dealers warranty. They said bring it in, then told me, "Your generator is broken so go to an Onan dealer". (Idiots)

Well, I got online to Onan and bought a new fuel filter (which I don't think was the problem) and a Service Manual.

After studying some, I went in to try adjusting the governor since that can cause problems like this, and found that one of the two plug wires was loose. And it just came to life, settled down, and started providing power.

Before this, I had voltage surges from 50 to 90 and the Hz were changing too fast to follow.

After, it worked correctly.

Anyway, be sure the simple stuff is working. Plugs, wires, fuel, governor adjustment (from service manual), etc.

good luck
__________________
John and Caren, Arkansas. 2006 Newmar Cypress 5th wheel. "Fractured Fairy tails"
johnandcaren is offline   Reply With Quote
Reply

Tags
emerald iii, generator, national, onan, surging



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pure Power opens Navistar engine research center in South Carolina DriVer Navistar MaxxForce Engine Forum 0 01-26-2010 03:02 PM
KVH Trackvision Power Switch Replacement Mike R Technology: Internet, TV, Satellite, Cell Phones, etc. 3 04-24-2009 05:48 PM
No aux power from house batteries John Trent Winnebago Industries Owner's Forum 7 02-17-2008 10:59 AM
Shore Power sjcaldal11 Newmar Owner's Forum 4 02-10-2008 05:35 AM
No Eletrical Power from Power Tech Generator Field Trip Newmar Owner's Forum 5 09-27-2005 05:23 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.