RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-01-2014, 04:40 PM   #1
Junior Member
 
Join Date: Feb 2013
Posts: 7
Blog Entries: 1
Hydraulic pump for leveling

does anybody know about hydraulic pump and motor on 2000 dolphin 5373?
water got in motor, took motor housing off with field coils and brushes, had to take "e" clip off back of armater to get housing off. armater will not come out of pump. i don't know if there is another clip or armater is stuck, also could not turn armater by hand and thus not turning pump.
any info will be greatly appreciated.
thanx, skip
__________________

omerwalters is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-04-2014, 06:09 AM   #2
Senior Member
 
Dmorgan6375's Avatar
 
Join Date: May 2013
Location: Unionville, Tenn.
Posts: 3,705
I wish I could be of help to you, but have you look at any of the links up at the top of the forum? If you can't find what you need there, try the forum group in Yahoo under the National RV and check their links to service and parts. Or just ask in the general MH section of either group.
__________________

__________________
Douglas M. Morgan RVM96
04 Dolphin 6375 LX W-24 Chassis #434136
"The Journey is our Destination" Unionville, Tn.
Dmorgan6375 is offline   Reply With Quote
Old 01-04-2014, 08:36 AM   #3
Junior Member
 
Join Date: Feb 2013
Posts: 7
Blog Entries: 1
thanx, i am going there today to see if wd40 broke it loose, if not can i get it rebuilt, checked with my rv mechanic and he said he could replace it and get air out of system, but he never got into motor and pump himself.
omerwalters is offline   Reply With Quote
Old 01-13-2014, 04:42 PM   #4
Senior Member
 
National RV Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2013
Location: Southern Lancaster County Pa
Posts: 962
The very best thing I have found to loosen anything like that is called 'Aerokroil'. I gave a can to a friend who wanted to loosen 4 bolts on an old wheelbarrow. He used WD40 on 2 and Aerokroil on the other 2. The bolts with the Aerokroil came off easy. The other two were a problem because the WD40 would not allow the Aerokroil to penetrate. Not sold in stores---look it up online.
Gerryl is offline   Reply With Quote
Old 01-22-2014, 07:52 AM   #5
Member
 
BoPeg's Avatar
 
Join Date: Oct 2011
Location: Orange Va
Posts: 96
Had the same problem with my 2000 Seabreeze. The motor will come apart you just have to play with it a bit. look closely how everything comes apart so it can be reassembled. this is not really a hard fix. Use some emry cloth to clean everything up and get a new bearing, NAPA has them in stock. When reinstalling pump motor run a bead of silicone around base before setting the motor. This will help keep water out in the future. This is a common problem with these units. You can do this.
BoPeg is offline   Reply With Quote
Old 01-23-2014, 09:55 PM   #6
Member
 
National RV Owners Club
Join Date: Dec 2011
Posts: 49
Same problem with TropiCal...took off top, worked armature back and
forth, finally loosened up, blew out rust with air, cleaned with
electrical cleaner, lubricated top bearing, sealed with silcone and
put top back on...works fine now...should have been sealed, in first
place, but wasn't....works fine now...have a great day..gene
__________________

Gene1 is offline   Reply With Quote
Reply

Tags
leveling



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.