RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-06-2012, 08:42 PM   #1
Junior Member
 
Join Date: Apr 2012
Location: Diamondhead, Mississippi
Posts: 23
Newbie need help

Newbie here just bought a 1994 Dolphin 32D ford chassis . It has a generac genset . The problem is my generator is not putting out to run a/c's . It cranks when I jump it off but will not produce any power. When I first looked at RV to purchace owner had it on battery charger and it cranked fine produced power to everything. Bought RV took on first trip this week. Got on road started Gen. after on road A/c would come on for 10seconds shut off come back on shut off. Now it will not do anything. I read some where if you are not getting enough volts to gen it will not produce power could this be the case. Because I know the previous owner did tell me the battery charger would not charge the batteries so he would just charge them with a seperate charger he bought at walmart. Any help would be appreciated.
__________________

fishingjohn is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-06-2012, 09:02 PM   #2
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Yuma Arizona USA
Posts: 2,788
If you have one of the NP series generators; shutting off the generator while it still has a load on it causes the regulator to go to full output as it tries to keep the voltage up while the generator is slowing down, which strains the regulator. Eventually it fails.

Here is the technical guide for the NP series generators.

It includes a troubleshooting flowchart and things to check before condemning the voltage regulator. If the engine is running close to the right speed you can skip to the "No AC Output" section.

Here is a more comprehensive troubleshooting guide.

The troubleshooting steps for no output start on Page 19.

Or you can just replace the regulator first and see if that solves the problem.
__________________

__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Old 04-06-2012, 09:20 PM   #3
Junior Member
 
Join Date: Apr 2012
Location: Diamondhead, Mississippi
Posts: 23
Thanks

Thanks will check tomorrow and update.
fishingjohn is offline   Reply With Quote
Old 04-08-2012, 04:09 AM   #4
Junior Member
 
Join Date: Apr 2012
Location: Diamondhead, Mississippi
Posts: 23
It was low voltage from house battery to generator. I called a generac service shop and they told me to charge my house batteries and start generator turn breakers on and see if led lite comes on on generator. The lite did not come on before fully charging batteries. So I put batteries on charger last night got up early this morning went out to motor home and started generator lite came on turn a\c's on both worked without a problem. So I guess even if you have enough juice to start and run generator if you don't have proper voltage from batteries generator will not produce power.
__________________
1994 National Dolphin 32D F53 Chassis
fishingjohn is offline   Reply With Quote
Old 04-08-2012, 05:21 AM   #5
Senior Member
 
Steve N Sal's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Join Date: Oct 2007
Location: Michigan
Posts: 5,658
I'm glad you corrected your problem and everything seems to be running OK.
I guess I've never heard of the batteries needing to be up to full charge for the generator to output electricity. The batteries have to be fully charged to start it but once it's up and running it's on it's own to produce AC power.
__________________
Steve & Sally / Hudson Our Little Pom / Heidi, Houston & HiTee Forever in our Hearts
04 NEWMAR MACA 3778 W22 / 05 PT Vert
Michigan (Summer) Michigan (Winter For Now)
Steve N Sal is offline   Reply With Quote
Old 04-08-2012, 07:27 AM   #6
Senior Member
 
clyon51's Avatar
 
Monaco Owners Club
Join Date: Mar 2012
Location: Arizona West RV Park, Yuma, Az
Posts: 4,229
In the Nationals, at least the earlier ones, the chassis battery is used for generator starting.

Like all RV generators, the governing power sourse is 12v. This power sourse comes from the 12v coach system, not the chassis system.

So, with dead coach batteries and no working charging system in place there was no 12v power to control the generator.

Fishingjohn: You need to get yourself a new coach charger. I would highly recommend a Progressive Dynamics PD 9245. You also need to know if your system will keep your chassis battery charged while parked. I suspect it doesn't. If not, there are easy and cheap ways to take care of this.
__________________
John & Clare Lyon
2007 43.5' Monaco Dynasty Palace III (All Electric)
Towd: 2011 Chevy Equinox
clyon51 is offline   Reply With Quote
Old 04-08-2012, 05:48 PM   #7
Junior Member
 
Join Date: Apr 2012
Location: Diamondhead, Mississippi
Posts: 23
Thanks for the info . I will be ordering the charger tomorrow.
__________________

__________________
1994 National Dolphin 32D F53 Chassis
fishingjohn is offline   Reply With Quote
Reply

Tags
newbie



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some advice on 2012 Denali TT thejean Travel Trailer Discussion 4 04-08-2012 09:58 PM
Bad Weather Driving Help zeeyaarv iRV2.com General Discussion 6 04-07-2012 04:32 PM
Help on locating Freightliner hub cover 22" Suncircles Winnebago Industries Owner's Forum 14 04-07-2012 10:48 AM
Need owners manual 1999 Infinify 30q chev dj98321 Class A Motorhome Discussions 0 04-06-2012 05:37 PM
hot water heater help kennyb79 Class C Motorhome Discussions 8 04-06-2012 08:16 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.