RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-21-2019, 02:37 PM   #1
Junior Member
 
Join Date: May 2019
Posts: 16
Question Speedometer/Odometer Troubleshooting Recommendations?

Took a quick 150 mile round trip this weekend and noticed on the way back, both the odometer and speedometer weren't working. We pulled over halfway back home for a different reason, shut the engine off, and once I started the engine back up everything started working again. This is a Cat engine w/ Allison tranny.

Anyone have this happen before, and if so, could you recommend a troubleshooting path?

Thanks,
Willie
__________________

__________________
Willie & Debbi Bifulco
Class A 1999 National Tradewinds DP
Forever grateful to Dwight & Sheila
Willie B is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-21-2019, 08:33 PM   #2
Member
 
C1v1leng's Avatar
 
National RV Owners Club
Vintage RV Owners Club
Join Date: Feb 2018
Posts: 70
Did you notice any odd messages on the transmission shift pad. Mine made weird symbols due to a power wire that was corroded. Following that it went into limp mode. Took quite a while to troubleshoot.
__________________

C1v1leng is offline   Reply With Quote
Old 07-22-2019, 06:34 AM   #3
Junior Member
 
Join Date: May 2019
Posts: 16
No messages that I noticed, but should it happen again, I'll make sure I look at the pad. Thanks for the tip.

Willie
__________________
Willie & Debbi Bifulco
Class A 1999 National Tradewinds DP
Forever grateful to Dwight & Sheila
Willie B is offline   Reply With Quote
Reply

Tags
speedometer



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer & Odometer billgriffith Class A Motorhome Discussions 4 10-12-2011 08:27 PM
Speedometer/Odometer Question wagatlen National RV Owner's Forum 1 07-10-2011 09:35 PM
Speedometer/Odometer Re Program RobRV Spartan Motorhome Chassis Forum 4 11-06-2009 02:47 AM
Speedometer/odometer quiting & other stuff SRT Ford Motorhome Chassis Forum 2 03-21-2006 07:51 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×