RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-03-2010, 09:36 PM   #1
Senior Member
 
National RV Owners Club
Join Date: Feb 2010
Posts: 172
Wait to start light goes off then back on

The "wait to start" light goes off after quite a few seconds with the ignition turned to aux, at which time I start the engine, but then it comes back on.. and the "prot. engine" light flashes really quickly and then both turn off.. is this normal?? The engine seems to run fine and there are no other lights coming on.
__________________

Thewellz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-03-2010, 09:42 PM   #2
Senior Member
 
Theberrys's Avatar
 
National RV Owners Club
Join Date: Jun 2009
Posts: 2,618
The Wait to start light in my 99 Tradewinds does the same thing sometimes. I don't recal the check engine light comming on. It has done this for the three years I've owned it and I've had no problems.

Dick
__________________

__________________
1999 Tradewinds 7372 Cat 3126
Albuquerque, NM
Theberrys is offline   Reply With Quote
Old 03-03-2010, 09:48 PM   #3
Senior Member
 
National RV Owners Club
Join Date: Feb 2010
Posts: 172
thanks for the quick response, I'm new to the world of pushers, wasn't sure if it meant a problem or not, also do you change your filters in your air brake system often?
Thewellz is offline   Reply With Quote
Old 03-04-2010, 06:57 AM   #4
Senior Member
 
Theberrys's Avatar
 
National RV Owners Club
Join Date: Jun 2009
Posts: 2,618
Wow I wasn't aware of Air Brake Filters. Sorry I'll be watching to see if some light gets shed on this subject.

Dick
__________________
1999 Tradewinds 7372 Cat 3126
Albuquerque, NM
Theberrys is offline   Reply With Quote
Old 03-04-2010, 05:30 PM   #5
Senior Member
 
National RV Owners Club
Join Date: Feb 2010
Posts: 172
I believe they are in the air drier system
Thewellz is offline   Reply With Quote
Old 03-04-2010, 06:06 PM   #6
Registered User
 
Monaco Owners Club
Join Date: Oct 2009
Location: Varies Depending on The Weather
Posts: 8,517
They are the same air drier filters used to dry the air in the storage tanks which are used to supply air to the air brakes and other items.

Your operators manual should have a list of all filters used throughout the DP.

Dr4Film ----- Richard.
__________________

Dr4Film is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Light Staying ON...... Capt Joe Workhorse and Chevrolet Chassis Motorhome Forum 44 06-05-2009 11:31 AM
Trany light and air conditioning??? roadtrec New Member Check-In 8 10-29-2007 04:24 AM
Step Light Wired Correctly? JavaJelly Newmar Owner's Forum 6 12-22-2006 11:31 AM
Patio and Curbside Security Light Not Working JavaJelly Newmar Owner's Forum 2 12-17-2006 08:03 AM
DP won't start. Fuses or Computer? Streff MH-General Discussions & Problems 2 03-04-2006 05:27 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.