RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-09-2011, 02:01 AM   #1
Registered User
 
jgaylor's Avatar
 
Winnebago Owners Club
Join Date: May 2011
Location: Prescott Valley, Arizona
Posts: 43
Send a message via Yahoo to jgaylor
Weldex Monitor & Camera May be Going Out

I recently purchased a 2006 Tropical m330. It has a Weldex 7" b/w monitor in the dash to the right of the instrument panel. Sometimes it works perfect and sometimes not. When it does not work the screen is blank, and at night there is no image even when I put it in night mode.

I talked with a gentleman at RVCams and he was very helpful. He said the b/w monitor is discontinued and replaced with a color one, that is compatible with the rear camera, however I have to purchase a new mount for the monitor.

I would like to go to a triview system, and he said I have to use Weldex side cameras. If I change to a different brand of monitor and cameras I have to run a new cable from backup camera to monitor. I did find on the internet a set of conversion cable adapters to allow the existing cable to be used with Audiovox Voyager Systems. I have no familiarity with Audiovox.

So my questions are :

Any idea what is up with my current system? (maybe loose connecor on back of monitor or camera)

Anyone swap out their Weldex system, if so what system did you use?

Lastly, anyone gone to a trivue camera system, and is it worth the expense?

Thanks for all your help, this is a great forum.

Jerry Gaylor Prescott Valley Arizona
__________________

jgaylor is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-09-2011, 06:10 AM   #2
Senior Member
 
ArmyEOD's Avatar
 
Join Date: Nov 2010
Posts: 419
I had the same issue with my color Weldex, turned out to be a lose connection at the camera end. Following a good reconnect, I took up the slack in the cable (it was just hanging down) this was creating a lot of stress. I now have it all secured and have had no more issues.

As for as the tri view, it came standard. I use my mirrors. The side cams have a lot of glare. just m 2cw.
__________________

__________________
George & Julie
06 Diplomat PDQ
ArmyEOD is offline   Reply With Quote
Old 09-09-2011, 06:24 AM   #3
Senior Member
 
ajm12's Avatar
 
Fleetwood Owners Club
Join Date: Apr 2011
Location: New Orleans, La.
Posts: 219
Quote:
Originally Posted by jgaylor View Post
I recently purchased a 2006 Tropical m330. It has a Weldex 7" b/w monitor in the dash to the right of the instrument panel. Sometimes it works perfect and sometimes not. When it does not work the screen is blank, and at night there is no image even when I put it in night mode.

I talked with a gentleman at RVCams and he was very helpful. He said the b/w monitor is discontinued and replaced with a color one, that is compatible with the rear camera, however I have to purchase a new mount for the monitor.

I would like to go to a triview system, and he said I have to use Weldex side cameras. If I change to a different brand of monitor and cameras I have to run a new cable from backup camera to monitor. I did find on the internet a set of conversion cable adapters to allow the existing cable to be used with Audiovox Voyager Systems. I have no familiarity with Audiovox.

So my questions are :

Any idea what is up with my current system? (maybe loose connecor on back of monitor or camera)

Anyone swap out their Weldex system, if so what system did you use?

Lastly, anyone gone to a trivue camera system, and is it worth the expense?

Thanks for all your help, this is a great forum.

Jerry Gaylor Prescott Valley Arizona
Had the same problem. Had some rough road then the monitor went blank. Check everything and could not find anything wrong. Spoke to RVCAMs in Baton Roge La. (found them on the internet) Very helpful. and was told that the weldex had problems with soldier joints coming loose. They had a replacement moldel that fits in the same spot and comes with all the adapters so you don't have to run any wires. It was a Voyager and it cost me a little over 200 bucks. If you want the info on these people let me know.
__________________
[SIGPIC][/SIGPIC] Al & Katie
2005 Excursion 39L Cat C7 350 HP
Retired 33 years NOFD and survived Katrina
ajm12 is offline   Reply With Quote
Old 09-09-2011, 06:26 AM   #4
Senior Member
 
HD4Mark's Avatar
 
Winnebago Owners Club
Coastal Campers
Join Date: Oct 2009
Location: Marathon, Florida
Posts: 2,909
Ours is a Sony but I can add my 2 cents about the side view cameras. The camera was in our rig when we purchased it and I assume factory installed. The side view cameras magically get changed to when you put on the directional. The good is that you get an instant view so you do not crush a car that was traveling in your blind spot when changing lanes. The bad is that if you where trying to keep an eye on your toad while going around a tight corner you can no longer see it in the rear view.

I don't see a way to change this on our camera but yours may work different. It would be optimal if there was a switch to sometimes disable the side view and leave just the rear on.

Even with the one small problem I would not trade the side cameras. It is nice to know nothing is next to you when you move over.
__________________
Mark & Nancy
2004 Winnebago Vectra 40KD
Shep dog, R.I.P. Kenzie dog Toad 2015 Jeep Wrangler Willys Wheeler
HD4Mark is offline   Reply With Quote
Old 09-10-2011, 05:35 AM   #5
Senior Member
 
Don and Kim's Avatar
 
Freightliner Owners Club
Join Date: Apr 2003
Posts: 216
We also had a very similar problem. At first I thought it might have been temperature related but it wasn't. I removed the rear camera and checked the connector. With the DW watching the monitor I could make the image come and go by wiggling the connector. I assume I had a broken connection at the rear camera connector. I cut the connector and soldered the wires directly eliminating the connector and haven't had an issue since.
Don and Kim is offline   Reply With Quote
Old 09-16-2011, 08:54 PM   #6
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: Ventura, Ca.
Posts: 327
Mine had the intermittent problem also. How it changed to a constant white screen, I have no idea. I checked both connection ends and both seemed solid.
__________________
2019 Winnebago Vista LX 30T, Honda CRV toad, best Labrador Retriever Charlie Brown .
Rocky 2 is offline   Reply With Quote
Old 09-17-2011, 08:00 AM   #7
Senior Member
 
Join Date: Oct 2009
Posts: 839
weldex

Same problem. Had to have it replaced. I am able to lock my cameras on either side or the back. I kept it locked on back all the time when traveling. It burnt out in a year and they replaced it no charge. I no longer travel with it in the rear locked position. Not a great system in my opnion.
FLYING BUTCH is offline   Reply With Quote
Old 09-22-2011, 11:59 PM   #8
Registered User
 
jgaylor's Avatar
 
Winnebago Owners Club
Join Date: May 2011
Location: Prescott Valley, Arizona
Posts: 43
Send a message via Yahoo to jgaylor
Weldex Monitor Is Out

Dealer verified weldex monitor is bad and there is no black/white made anymore so it will be replaced with color under warranty, at least that is the plan, just waiting for warranty insurer to ok it.
__________________

jgaylor is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weldex Rear Vision Camera countrypair RV Systems & Appliances 6 09-05-2011 06:56 AM
Weldex 3007 M rear camera troubles adamson Class A Motorhome Discussions 6 07-18-2011 08:22 PM
Weldex Camera Mirror Image Help FOSJ iRV2.com General Discussion 3 09-06-2010 08:45 AM
Weldex camera system issue wizzo442 Monaco Owner's Forum 2 05-18-2010 05:14 AM
Weldex Camera kcir MH-General Discussions & Problems 1 12-14-2007 02:22 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.