RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-04-2019, 02:16 PM   #1
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
When it rains, It pours--HELP

1. I posted about my generac generator not staying on while moving and that it would stay on if I wasn't moving.
Well now it won't stay on sitting either.

THIS GETS BETTER
2. I posted about my Dometic fridge NDR1292 not cooling and that the end of June a "certified" Dometic mechanic came to look at it. He disconnected a white wire and never called, answered or came back. I started using a tall house fan outside blowing towards the back of the fridge, it actually did cool better. So I shut down the fan and fridge and the next day my propane alarm went off so I shut the tank off, (wasn't using it anyway) was told that these things only last 5 years. Then later that day the Carbon monoxide detector started beeping, when I opened the door it really smelled bad. So now I knew I needed a new cooling unit for sure.

3. I have an appointment on this Tuesday for this RV place to look over the interior so they can give me a solid quote to replace the cooling unit inside the mh on the floor.

Here's the straw that is breaking this Camels back.

I have fully charged batteries and when I went to start the MH it made a few funny noises and then nothing. The dash lights won't come on at all. So I got out and checked the fuses in that rear side compartment and found a blown 15amp fuse, love the way they have a little red light to show you which one is bad.
I thought easy fix, sure not for me. After trying two new fuses and getting them blown as soon as the made contact I quit.

Funny thing I tried the generator and it has power to start.

ANYONE REMEMBER THE KID WITH THE RAIN CLOUD OVER HIS HEAD? Well he's alive and here in Saint George, Utah.

I looked all through the books I have but none show the Fuses.

Here's the question--Does anyone know what this 15amp fuse goes to and why is it blowing new ones. It is marked as F20
__________________

__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-04-2019, 02:27 PM   #2
Senior Member
 
gfs1943's Avatar
 
Monaco Owners Club
Join Date: Sep 2011
Location: Whitney, TX
Posts: 422
The reason it's blowing new fuses is the same reason the first one blew. Something in that circuit (whatever it is) is pulling too much amperage. Find what the circuit goes to, and explore the components and wiring to determine what's wrong.
__________________

__________________
USAF, Retired (1962 - 1983)
2006 Monaco Diplomat 40 PRQ
2006 Honda CR-V Toad
gfs1943 is offline   Reply With Quote
Old 08-04-2019, 02:37 PM   #3
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
That's why I posted the fuse # on the National forum, hoping someone has a book on these fuses so I can see what it goes to. It's on a large circuit board with several other fuses.
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 08-04-2019, 04:26 PM   #4
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
Thought I would add some more info. Not only does the ignition not work, but neither do the head lights or the cigarette lighter. The knob for the heater or the a/c doesn't work. But if I try the fantastic fan and bathroom fan they work. Even the water pump switch works. But I can start the generator.
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 08-04-2019, 04:41 PM   #5
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
Also nothing on the dash comes on, not even the annoying buzzer until it would start.
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 08-06-2019, 02:44 PM   #6
Senior Member
 
BOOZE TRAVEL's Avatar
 
National RV Owners Club
Join Date: Aug 2017
Location: Pendleton, In.
Posts: 180
Seems as though the things not working are on chassis batteries and fuse blocks. The things you are saying still work are on the house batteries. You may be able to call the chassis manufacturer and ask about that fuse slot.
BOOZE TRAVEL is offline   Reply With Quote
Old 08-06-2019, 04:34 PM   #7
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
Ok folks keep your fingers crossed. My 4 6volts tested good but my two 12volt chassis tested 0 and 2. Got new ones, paid a neighbor kid to put all 6 batteries in, now I need to wire them up and hope this was the problem. Let you all know later.
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 08-06-2019, 08:44 PM   #8
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
Oh Happy Days, all connected, fired her up and running great. Still hard to believe that 2 bad 12volt chassis batteries were the cause of blowing a 15amp fuse 3 times. BTW, these old chassis batteries were purchased about 9-10 years ago.

Nice to have the rain stop. lol
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 08-14-2019, 08:48 PM   #9
Junior Member
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Jun 2011
Location: Central Coast, Calif.
Posts: 9
While traveling in "HOT WEATHER", I had a similar problem with my generator. I was able to start my generator, but then it shut off. What I discovered; I had the generator serviced and oil changed. The oil level was to high. I drained some of the oil and it worked perfect traveling down the road. From what I could research; when checking a level of oil in the generator, there is one stick that you screw on completely and one you just dip the stick in the pan.

Hope this helps
Dale
dricha4169 is offline   Reply With Quote
Old 08-14-2019, 09:17 PM   #10
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 1,933
She's going in to a certified Generac shop tomorrow. He's going to run a few tests.
__________________

__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
when it rains it pours... Vintagercr Monaco Owner's Forum 15 11-19-2017 10:24 AM
Oh my, when it rains it pours, lotsa problems all at once. RCtime Winnebago Industries Owner's Forum 19 05-19-2013 06:13 PM
Polar-Aire leaking during heavy down pours rgriffin46 Class A Motorhome Discussions 3 05-23-2012 02:45 AM
when it rains it pours jdsr Winnebago Industries Owner's Forum 12 09-03-2007 01:34 PM
Beep-Beep-Beep when it rains with 2004 Diplomat bg1811 Monaco Owner's Forum 12 07-20-2007 04:05 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.