RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-22-2013, 05:15 AM   #1
Senior Member
 
Tiffin Owners Club
Join Date: Jun 2008
Posts: 614
Air bags not deflating when putting jacks down '03 Phaeton

I recently noticed that the air bags are not deflating anymore when I put the jacks (HWH) down on our 03 Phaeton. It seemed to me that before, I soon as I hit the power on on the jack control, it would dump the air. Is this a common issue? Any idea what I should be looking at to fix this?

Let me know. Thanks,
Mike
__________________

michelb is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-22-2013, 05:54 AM   #2
Senior Member
 
Join Date: Feb 2011
Location: Snowbird - Waterford Mi and Citrus Springs Fl.
Posts: 3,609
Mine is a manual control. Panel power on, push the dump button until it stopps hissing.

When I got mine, the front would lower, but not the back. In troubleshooting, I found the rear valve fully functional, but the outlet blocked, courtesy of a thoughtless mud dauber?

I would doublecheck your operating directions to make sure you're using the controls properly. If so, troubleshooting not that hard? Just pay attention if you're under it. That would be a heck of a time for it to start working?
__________________

__________________
1997 37' HR Endeavor, 275hp Cat, Freightliner
03 CR-V Blue Ox, Ready Brake
ahicks is offline   Reply With Quote
Old 05-23-2013, 06:47 AM   #3
Senior Member
 
Tiffin Owners Club
Join Date: Jun 2008
Posts: 614
Thanks for the info. I've seen the panels with the 'dump' button but mine is doesn't have one (looks identical except that this button doesn't exist).

I'll look for a blocket outlet though - never even occured to me to look for that.
michelb is offline   Reply With Quote
Old 05-26-2013, 10:00 AM   #4
Senior Member
Commercial Member
 
Join Date: Jun 2005
Location: behind the steering wheel
Posts: 1,582
if its a freightliner chassis, the dump valve is above the front axle. it needs a signal to either dump or inflate the bags. there is a manual switch on the valve to shift it so you can go to ride height. most of the time, its a defective valve. you can check both connections for 12 volts.
there is a page in your service manual that goes thru a diagnosis for this valve. the led guide will tell you which led to check in the control box.if you go under the coach, be sure to use frame blocks or jack stands to keep the chassis from moving lower while you are under it. this is a freightliner part, if its a rectangular part, and has red slide switchs on both sides.
if its in the rear, and is round, and mounted just back of the rear axle, its a hwh part.it will have a hwh part number on the harness tag. check the opening. it gets filled up with road grime. clean it out, and check for 12 volt while dumping sequence is activated.
azpete is online now   Reply With Quote
Old 05-27-2013, 05:25 AM   #5
Senior Member
 
Tiffin Owners Club
Join Date: Jun 2008
Posts: 614
Thanks for the info azpete. That's perfect. I'll have a look at all that (bought the mh used with no manuals so I'm doing this a bit blind)
michelb is offline   Reply With Quote
Old 05-30-2013, 11:56 PM   #6
Senior Member
 
historyljc's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Feb 2008
Location: Pensacola, Florida
Posts: 5,173
If you can't work it out, call Brett in Tiffin service. 256-356-2769. He's answered a lot of jack questions for me.
__________________
Travel well, travel safe,
Jim
2006 Tiffin Phaeton - 2011 Cadillac SRX
historyljc is offline   Reply With Quote
Old 06-25-2013, 05:16 AM   #7
Senior Member
 
Tiffin Owners Club
Join Date: Jun 2008
Posts: 614
In case anyone has the same problem. I should have checked the easiest thing first. Turns out that the fuse for the dump signal had blown. The HWH panel is actually very easy to troubleshoot (there are LEDs all over the place).

The hardest thing is to find the model number and the manual that matches that model (Ours appears to be a 325 - even with that, there are still a few 325s to choose from). The only catch is that changing the fuse requires removing the plexiglass cover on the HWH board enclosure and putting the cover back wasn't all that easy (there's a rubber seal all around that you have to 'pull / roll' over the edge).
michelb is offline   Reply With Quote
Old 06-28-2013, 05:05 PM   #8
Senior Member
 
Melmoses's Avatar
 
Tiffin Owners Club
Join Date: Aug 2010
Location: Montgomery, AL
Posts: 1,197
Thanks for the follow up. Gained some knowledge from it. Glad you got the issue fixed!
__________________

__________________
Mel (Melanie) and Harry
2009 Tiffin Phaeton 40QTH
2014 Jeep Wrangler Sport
Melmoses is offline   Reply With Quote
Reply

Tags
jacks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Advent Air conditioner builder RV Systems & Appliances 14 11-09-2016 05:32 PM
Hydraulic Jacks scooterbob Class A Motorhome Discussions 12 06-07-2013 04:44 PM
Air gauge going crazy 2000 Dutchstar clarkbar Class A Motorhome Discussions 7 06-06-2013 05:55 PM
Flood lamps under rear air spoiler, no switch? 2000 Ultimate Freedom 40JD Ray,IN Winnebago Industries Owner's Forum 19 06-04-2013 05:58 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×