Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Motorhomes Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-12-2016, 05:58 PM   #1
Member
 
BeerLover80's Avatar
 
Tiffin Owners Club
Join Date: May 2015
Location: Lothian, MD
Posts: 64
Another Noodle Scratcher

So my DVD player is pushing audio but not video. It's getting a signal because the "No Input" isn't coming up. All connections are solid. Any thoughts?

2016 Allegro RED 38QBA
__________________

__________________
Tim Billings
Tiffin 2016 Allegro RED 38QBA
BeerLover80 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-13-2016, 12:43 AM   #2
Senior Member
 
Join Date: Jul 2011
Posts: 951
Is your "source" set to DVD on the TV menu?
__________________

__________________
2004 Tiffin Allegro 27.5 ft. P32 18,000 lb GVW. 8.1 liter. Workhorse chassis built May 2002. 21,000 miles. 2012 Jeep Liberty Toad. RVi2 brake unit.
Full.Monte is offline   Reply With Quote
Old 03-13-2016, 03:06 AM   #3
Member
 
Join Date: Mar 2014
Posts: 65
Box of many buttons, got one, is dvd selected?
Chances are you have surround sound, or sound bar, and it may take it's audio feed separate to the video?
__________________
Si, Sarah and Shelby the westie
2008 Damon Daybreak 3070
98 TJ, 4" lift, 31s, usual stuff
Dodgey is offline   Reply With Quote
Old 03-13-2016, 06:16 AM   #4
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 2,525
Quote:
Originally Posted by Dodgey View Post
Box of many buttons, got one, is dvd selected?
Chances are you have surround sound, or sound bar, and it may take it's audio feed separate to the video?
BOMBs are not used by Tiffin.

Your audio is playing through your surround speakers and you have not selected your input on whichever TV you want to watch. Pick a TV, press the source button, and select DVD. You should be fine.
__________________
Roger & Mary
2017 Winnebago Navion 24V
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Old 03-13-2016, 07:00 AM   #5
Member
 
BeerLover80's Avatar
 
Tiffin Owners Club
Join Date: May 2015
Location: Lothian, MD
Posts: 64
But it's not playing to any of my TV's...we have 4. All 4 have sound but no picture. How did all 4 suddenly lose their input?
__________________
Tim Billings
Tiffin 2016 Allegro RED 38QBA
BeerLover80 is offline   Reply With Quote
Old 03-13-2016, 07:14 AM   #6
Senior Member
 
Join Date: Nov 2015
Posts: 4,934
Quote:
Originally Posted by BeerLover80 View Post
But it's not playing to any of my TV's...we have 4. All 4 have sound but no picture. How did all 4 suddenly lose their input?

Have you selected 'DVD' (HDMI-1 or whichever channel the dvd player is on) for each TV?

Just turning on DVD player doesn't automatically swap TV input to correct channel/input for DVD
__________________
Old-Biscuit is online now   Reply With Quote
Old 03-13-2016, 07:21 AM   #7
Member
 
BeerLover80's Avatar
 
Tiffin Owners Club
Join Date: May 2015
Location: Lothian, MD
Posts: 64
Correct.
__________________
Tim Billings
Tiffin 2016 Allegro RED 38QBA
BeerLover80 is offline   Reply With Quote
Old 03-13-2016, 08:16 AM   #8
Senior Member
 
Bill2's Avatar
 
Tiffin Owners Club
Join Date: Jan 2009
Location: Somewhere on the road
Posts: 438
Quote:
Originally Posted by BeerLover80 View Post
So my DVD player is pushing audio but not video. It's getting a signal because the "No Input" isn't coming up. All connections are solid. Any thoughts?

2016 Allegro RED 38QBA
Check your HDMI splitter probably somewhere run your DVD player I had one of them go bad in my coach and had to replace it
__________________

__________________
Bill2 is offline   Reply With Quote
Reply

Tags
scr



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator head scratcher David Hay RV Systems & Appliances 4 07-20-2015 06:39 PM
Head scratcher dscotty99 Ford Motorhome Chassis Forum 1 09-25-2014 06:31 AM
Onan Head Scratcher kratzkr RV Systems & Appliances 1 05-20-2014 08:28 AM
Noodle joannel Class A Motorhome Discussions 10 01-15-2014 12:52 PM
canopy noodle placement baldrudy iRV2.com General Discussion 14 09-17-2013 06:16 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.