Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Motorhomes Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-28-2014, 05:24 AM   #1
Junior Member
 
Join Date: May 2014
Posts: 17
Kwikee steps on 13 35 QBA not extending (going out)

Just got to Fort Wilderness last night but about 700 miles into the trip and 2nd day of travel opened door and steps don't go out. This happened about a month ago on a trip and when I got home I checked all the fuses and then unplugged the harness underneath the coach that goes to the steps and plugged back in and they started working again. Worked all that time until yesterday. Suggestions on what to check next? I'm thinking loose with somewhere. Should I pull the switch panel at the door and check there next? Is there a way to manually put the steps out? It's a long way down/up with out the steps. Thanks in advance for any help/directions.
__________________

__________________
colter is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-28-2014, 05:36 AM   #2
Senior Member
 
Shellback1's Avatar


 
Damon Owners Club
Ford Super Duty Owner
Join Date: Jul 2008
Location: Nashua, NH
Posts: 721
Send a message via AIM to Shellback1
Clean your ground wire. Mine did that too, was the motor. I changed it and all has been fine.
__________________

__________________
2006 Damon Daybreak 3274 35' Ford F53 V-10
2006 Ion Retired Navy, FAA and PASS Union VP
Shellback1 is offline   Reply With Quote
Old 06-28-2014, 07:35 AM   #3
Senior Member
 
OSP1268's Avatar
 
Join Date: Oct 2010
Location: Central Florida
Posts: 524
As a suggestion to try! With the door open, so the steps would normally go out, tap on the motor gently with a hammer. Just make sure you are not laying anywhere near where the steps would travel or you will get pinched if they come out. Also make sure all pivot points are lubricated. If that doesn't work you may need a new motor.
__________________
R & E
No RV at the moment
OSP1268 is offline   Reply With Quote
Old 06-28-2014, 07:52 AM   #4
Senior Member
 
dabrooks's Avatar
 
Tiffin Owners Club
Join Date: Sep 2012
Location: Maryland
Posts: 1,000
It could be something as simple as the door switch. Remember when you are trouble shooting the steps keep your hands fingers and other body parts away from moving parts. If you are down looking under the coach they can even hit you in the face.

There is a design flaw in the 35 QBA that allows water to get to the door switch connections from the passenger wheel well. I f you take the switch out you can check for voltage at the switch. Two screws hold it in and it comes out from the door jamb side. If you do have 12 volts on one side and not on the other side you can take the wires off the switch and touch them together and see if the steps move. Again remember keeps clear of the steps at all times because they can move at any time especially if something is corroded.
__________________
dabrooks is offline   Reply With Quote
Old 06-28-2014, 08:04 AM   #5
Senior Member
 
hydro45640's Avatar
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Apr 2013
Location: Jackson,Ohio
Posts: 276
Try oiling the pivot points on the steps.
__________________
hydro45640 is offline   Reply With Quote
Old 06-28-2014, 08:38 AM   #6
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 2,272
The door switch is the most likely source of the problem. The plunger gets a bit of corrosion on it coupled with the normal gap between the door and the jamb and things stop working.

Open the door and push on the switch with your finger. Do the steps work? Give the switch a quick shot of silicon spray and you should be good to go - for awhile. Add it to your routine maintenance list.
__________________
Roger & Mary
2017 Winnebago Navion 24V
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Old 06-28-2014, 04:00 PM   #7
Junior Member
 
Join Date: May 2014
Posts: 17
The light comes on when the door opens, so doesn't that mean the switch is ok? I went through all the electrical tests on the 4way plug per the manual and all voltages were correct. So that makes me think the motor is the issue- correct? Or am I missing something?
__________________
colter is offline   Reply With Quote
Old 06-28-2014, 04:23 PM   #8
Senior Member
 
JacknKay's Avatar
 
Tiffin Owners Club
Join Date: Apr 2011
Posts: 594
Kwikee steps on 13 35 QBA not extending (going out)

Mine had the same issue, light on but no action. Remove the motor and take it apart to clean the armature. I might work after that. Mine did. That said I did order a new motor, (from Amazon) and gearbox as a back up. My steps still go in and out after the cleaning.


Sent from my iPad using iRV2 - RV Forum
__________________
Jack & Kay
2015 Allegro 32CA Ford Chassis
FMCA #341229
JacknKay is offline   Reply With Quote
Old 06-28-2014, 05:05 PM   #9
Member
 
Tiffin Owners Club
Texas Boomers Club
Ford Super Duty Owner
Join Date: Jul 2012
Location: Baytown, TX.
Posts: 61
Water

Quote:
Originally Posted by colter View Post
Just got to Fort Wilderness last night but about 700 miles into the trip and 2nd day of travel opened door and steps don't go out. This happened about a month ago on a trip and when I got home I checked all the fuses and then unplugged the harness underneath the coach that goes to the steps and plugged back in and they started working again. Worked all that time until yesterday. Suggestions on what to check next? I'm thinking loose with somewhere. Should I pull the switch panel at the door and check there next? Is there a way to manually put the steps out? It's a long way down/up with out the steps. Thanks in advance for any help/directions.
Water gets inside the connection
__________________
WBBB1 is offline   Reply With Quote
Old 06-28-2014, 07:23 PM   #10
Senior Member
 
coachmanrvr's Avatar
 
Entegra Owners Club
Join Date: Dec 2008
Location: Chattanooga, TN
Posts: 686
Our 2013 35 QBA ended up having a bad motor. I originally thought it was water and the door switch but the motor ended up the solid fix.

35QBA / 36LA Step Door Switch and Water
__________________
2012 Entegra Aspire
2012 Nissan Xterra Pro4x Tow
Ready Brute Elite
coachmanrvr is offline   Reply With Quote
Old 06-28-2014, 10:05 PM   #11
Junior Member
 
Join Date: May 2014
Posts: 17
Ok- thanks for all the info. I did knock on the motor a few times then press the switch a number of times with the door open and nothing. Then, I kid you not, 2 minutes later my wife opens the door to go in and bam- out the steps come! What the heck?? Oh well, hopefully they will keep working til we get home. Who knows. I will definitely pull and clean the switch when we get to Daytona and get another motor when we get home.
__________________
colter is offline   Reply With Quote
Old 06-29-2014, 07:16 PM   #12
Senior Member
 
JacknKay's Avatar
 
Tiffin Owners Club
Join Date: Apr 2011
Posts: 594
It's a dirty armature on the motor. Mine did the same thing, work, then not work.


Sent from my iPad using iRV2 - RV Forum
__________________

__________________
Jack & Kay
2015 Allegro 32CA Ford Chassis
FMCA #341229
JacknKay is offline   Reply With Quote
Reply

Tags
kwikee, steps



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kwikee Steps acting in reverse flintw Class A Motorhome Discussions 29 06-28-2014 05:36 AM
Replacing Kwikee steps driedl Newmar Owner's Forum 2 04-23-2014 11:53 AM
Kwikee Steps Lt46 MH-General Discussions & Problems 15 02-23-2014 04:48 PM
Kwikee Steps not retracting all the way Ragman Class A Motorhome Discussions 7 01-15-2014 12:50 PM
DSDP - Steps not Extending JCAT Newmar Owner's Forum 14 06-30-2013 06:39 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.