RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2019, 09:33 AM   #1
Junior Member
 
Join Date: Jul 2019
Posts: 8
Levelegs

I have a 2008 32 foot Open Road with Atwood Levelegs system. We have only jad it for a couple months. We are camping and the legs won't lower and the control panel won't turn on. The five lights that are verticle on the left side keep scrolling top to bottom.
I called my salesman because the maintainence shop was closed. He said it sounded like a short.
Has anyone had this issue and a solution?
Lucily we are on a level pad and he said it wouldn't hurt to put the slides out.
Thanks
__________________

craigtoups is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-18-2019, 04:56 PM   #2
Member
 
accsys's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Mar 2007
Posts: 63
I have attached the Atwood manual. Be sure and check page 5 for troubleshooting. It sounds like you have a communication error between the control pad and the control unit or it needs to have the auto level set up.
Attached Files
File Type: pdf Atwood Levelegs.pdf (330.3 KB, 8 views)
__________________

__________________
John and Doris
2007 Tiffin Phaeton 40 QDH (The Mothership), 2004 Jeep Liberty 4x4 (Libby)
Our Blog covering trips from 2008 to present
accsys is offline   Reply With Quote
Old 09-21-2019, 12:12 PM   #3
Junior Member
 
Join Date: Jul 2019
Posts: 8
trying to check this out but have no idea where it is or what the control unit looks like. the control panel on the dash has 4 wires coming out and my meter shows 4.2 v. don't know where or how to check the rest. Can anyone enlighten me?
craigtoups is offline   Reply With Quote
Old 09-22-2019, 07:13 AM   #4
Senior Member
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2011
Location: South Chesterfield, Virginia
Posts: 344
Mine is in the basement storage bay on the passenger side below the passenger seat.
Catch14me is offline   Reply With Quote
Old 09-22-2019, 08:21 AM   #5
Member
 
accsys's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Mar 2007
Posts: 63
You are looking for a black metal plate bent into a shallow u-shape and two screws in each end, usually attached to the roof of the compartment. You cannot see the circuit board without removing the unit from the ceiling but you can see the wiring going to it. As Catch14me said, it is usually in the front most passenger side bay on the diesels - not sure about your Open Road.
__________________
John and Doris
2007 Tiffin Phaeton 40 QDH (The Mothership), 2004 Jeep Liberty 4x4 (Libby)
Our Blog covering trips from 2008 to present
accsys is offline   Reply With Quote
Old 10-06-2019, 12:12 AM   #6
Senior Member
 
PapaBobby's Avatar
 
Join Date: Jul 2011
Location: CA
Posts: 177
We have e a 2007 Open Road TSA 35 and had the same problem. My jacks would intermittently "fail," but I was able to get the system activated by pressing the the ON button for up to 30 seconds, sometime more. Fortunately, I've always gotten to jacks down and, more importantly, up. I spoke to "Sue" at the company who mentioned they were aware of the problem. She indicated there is a newer control panel that is made for the newer system, but didn't know if it would work on the older systems. Unfortunately, she is no longer there.
__________________

PapaBobby is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Levelegs system DandS Newmar Owner's Forum 33 09-17-2012 10:18 PM
Atwood Levelegs millerdp MH-General Discussions & Problems 1 08-25-2010 03:56 AM
Atwood Levelegs Electric Jack System Failed - UPDATE GerryB54 Fleetwood Owner's Forum 18 06-25-2009 09:26 AM
Atwood Levelegs rbuddy Newmar Owner's Forum 2 09-27-2008 06:07 PM
Atwood LeveLegs... RobbieR Workhorse and Chevrolet Chassis Motorhome Forum 2 04-23-2007 08:53 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×