Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Motorhomes Owners Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-15-2011, 07:57 PM   #1
Junior Member
 
Tiffin Owners Club
Join Date: May 2011
Posts: 2
Lights, Turn signals, map light

We just bought a 2005 Allegro bus. We are pulling an enclosed car trailer. We checked all the lights before we left home and all was fine.

Last night there was a huge rain storm and when we got up to leave this morning, the headlights would not come on. The turn signals did not work. The map light is not functioning. The tail lights did not work. We did not locate any leaks but this was the only thing that happened out of the norm.

The wind shield wipers did work.

If we applied the brakes, and used the turn signal we could make the light flash, (off and on, not brighter like a brake light).

We checked all the fuses in the panel between the seats but all looked good.

Where is the flasher, and could a bad flasher cause all of this. Doesn't seem like it should; to us.

Any words of wisdom would be appreciated.

Thanks, Jim & Majyk
__________________

__________________
majykstella is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-15-2011, 08:39 PM   #2
Senior Member
 
SVTotem's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Feb 2010
Location: Orlando, FL
Posts: 626
Jim is this on a Frieghtliner chassis?

I had similar symptoms on my 05 Journey with Frieghtliner XC chassis. It was a bad lamp controller module located under the dash forward of the steering column. The FCCC part number of the controller is 06-44311-000 and manufactured by InPower.

The removed part was about 3x5 and has two large connectors if that helps you identify it. The new part was considerably larger, but the replacement was certainly a DIY job.

If you have a FCCC chassis give their customer support line a call to confirm this for your application.
__________________

__________________
Bill Burgner, '05 Journey, 350 CAT
'05 Wrangler LJR, Blue Ox Aventa, Air Force One
www.retirement-ramblings.blogspot.com
SVTotem is offline   Reply With Quote
Old 05-16-2011, 08:49 AM   #3
Senior Member
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 15,546
If you have a WORKHORSE chassis, then under the hood, more or less top and center, is a unmarked black box.. on the bottom of this box are to brass (I think) studs (Just below the box and part of it) If you look on the sides you will see the latches for the box cover.

It is a fuse box.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 05-16-2011, 09:16 AM   #4
Junior Member
 
Tiffin Owners Club
Join Date: May 2011
Posts: 2
Thank you so much. Freightliner it is.
__________________
majykstella is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vectra turn signals glenda1908 Winnebago Industries Owner's Forum 10 06-13-2010 09:22 PM
Drivers map light bairdofl Newmar Owner's Forum 2 05-31-2010 08:08 PM
YOUR TOAD TURN SIGNALS ARE WIRED WRONG Turrable Terry MH-General Discussions & Problems 3 09-04-2007 04:24 AM
Towing a Toad w/ amber Turn Signals w/ Journey Pusherman Winnebago Industries Owner's Forum 7 02-22-2007 03:43 AM
Turn signals glenda1908 Winnebago Industries Owner's Forum 22 11-21-2005 12:59 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.