RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-27-2014, 01:27 PM   #1
Senior Member
 
Join Date: Sep 2013
Location: Joppatowne, Maryland
Posts: 182
Looking for Help - Rear Camera

We have a 2014 -36LA Tiffin when we coming across route 16 in Georgia we hit a lot of road joints and our rear camera went out and never came back on. I removed it from camper thinking maybe a plug came lose. No such luck. Talked to local dealer and they can't get to us till July 7th. Any one else have this problem?
__________________

grizz427 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-27-2014, 03:16 PM   #2
Member
 
Charles G.'s Avatar
 
Tiffin Owners Club
Join Date: Jan 2010
Location: Oakdale, Louisiana
Posts: 50
Hey grizz427:

Try the tiffinrvnetwork.com forum as I am sure you will get answers. Sorry you had a problem. No fun when the rear camera goes out. Travel safe.

Charles G.
__________________

__________________
Charles & Wanda (Oakdale, Louisiana)
2012 Tiffin Alegro Bus 40QBP - Chevy Equinox(Toad)
FMCA-417263
Charles G. is offline   Reply With Quote
Old 05-27-2014, 03:21 PM   #3
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 4,993
What makes you think its the camera and not the video display end of things--do you have side views still working? Fact is most/many folks travel/drive with the camera off--they think its a "distraction" while driving.
__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 05-27-2014, 03:30 PM   #4
Senior Member
 
sirpurrcival's Avatar
 
National RV Owners Club
Join Date: Apr 2010
Posts: 1,077
I was going to say the very thing. Had that a while back and it turned out it was the connection at the monitor end, not the camera. Whats worse, to look at it, you couldn't tell.
__________________
1999 - National Tropi Cal
sirpurrcival is offline   Reply With Quote
Old 05-28-2014, 08:27 AM   #5
Senior Member
 
Join Date: Sep 2013
Location: Joppatowne, Maryland
Posts: 182
thanks for the input on this. I do still have the left and right camera working just when it goes to rear it states A/V out blue screen. Well I climbed up the back and started tracing the wires from camera back down so far I've come across a 1amp fuse but all plugs connected I'm replacing fuse to day and then starting back from dash.
grizz427 is offline   Reply With Quote
Old 06-03-2014, 06:51 PM   #6
Senior Member
 
Join Date: Sep 2013
Location: Joppatowne, Maryland
Posts: 182
Thanks for your interest

Well just wanted to thank you all for the info and the help in solving my problem. As it was stated it was that Dam fat cat of mine from playing under the dash she had separated the cord for the rear camera. Plugged back in and good as new. Guess I'll have to get the cattle prod out for her the next time
__________________

grizz427 is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parking Brake Alarm and Rear Camera CoreyinWP Entegra Owner's Forum 14 04-18-2014 10:19 PM
2006 Signature rear camera ptrombetta Monaco Owner's Forum 4 03-26-2014 04:41 PM
Help rear camera problem. ShadowBolt Entegra Owner's Forum 19 03-13-2014 11:40 AM
Power to rear camera - upgraded system 04Beast Newmar Owner's Forum 10 01-28-2014 05:07 PM
Squirrely rear camera RJEV MH-General Discussions & Problems 8 06-08-2013 03:39 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.