RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2014, 06:55 PM   #1
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2014
Location: Whitehouse Station, NJ
Posts: 661
New owner - first problem

Picked up motorhome for first local trip from dealer storage. Got to campground and smelled propane. Leaving from main tank valve hose connection to regulator. Do no hot water or first night. Well have to call dealer in the morning. Welcome to rv ownership I guess.
__________________

__________________
Randy & Ella (terrier mix rescue)
2013 Tiffin Phaeton 40QBH
2014 Ford Edge
mricet1005 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-09-2014, 07:15 PM   #2
Senior Member
 
Cart's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Mar 2013
Location: N. Texas
Posts: 281
I'm sure you cut off the main valve. Be careful this could be very dangerous. There should be someone there in the campground that could help you with the problem. It may just be a bad or loose fitting. You can check to see where the leak is by putting soapy water around the connections and look for bubbles.
__________________

__________________
Jim,Ginny and Abbie (schnauzer)
RVM 58
Thor Hurricane MH - Jeep Wrangler
Cart is offline   Reply With Quote
Old 05-09-2014, 07:25 PM   #3
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2014
Location: Whitehouse Station, NJ
Posts: 661
I used soapy water to verify leak. I have shut off the main valve. Tried tightening the connection. Made it leak faster. Will have to pursue help tomorrow.
__________________
Randy & Ella (terrier mix rescue)
2013 Tiffin Phaeton 40QBH
2014 Ford Edge
mricet1005 is offline   Reply With Quote
Old 05-10-2014, 07:03 AM   #4
Senior Member
 
Ramets's Avatar
 
Join Date: Jul 2010
Location: Conway, SC
Posts: 2,482
Sounds like a cross threading problem. Which could be worrisome since it should be a brass fitting.
Ramets is offline   Reply With Quote
Old 05-10-2014, 07:05 AM   #5
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2014
Location: Whitehouse Station, NJ
Posts: 661
Threading seems to be ok. I completely disconnected hose and threads looked fine.
__________________
Randy & Ella (terrier mix rescue)
2013 Tiffin Phaeton 40QBH
2014 Ford Edge
mricet1005 is offline   Reply With Quote
Old 05-10-2014, 12:34 PM   #6
Senior Member
 
Join Date: Apr 2010
Location: SW, Michigan
Posts: 628
Quote:
Originally Posted by mricet1005 View Post
Picked up motorhome for first local trip from dealer storage. Got to campground and smelled propane. Leaving from main tank valve hose connection to regulator. Do no hot water or first night. Well have to call dealer in the morning. Welcome to rv ownership I guess.
Your Phaeton should also have a switch for electric to heat the water. I believe the switch is in the panel over the drivers head.
If we are in a campground with power we always run the water heater with electric.
__________________
2010 Allegro RED 36 QSA
GMC Envoy 4x4
SW Michigan to Alaska in 2015
okgc is offline   Reply With Quote
Old 05-10-2014, 12:56 PM   #7
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by mricet1005 View Post
Picked up motorhome for first local trip from dealer storage. Got to campground and smelled propane. Leaving from main tank valve hose connection to regulator. Do no hot water or first night. Well have to call dealer in the morning. Welcome to rv ownership I guess.
mricet1005T
Welcome.
If you intend to keep the motor home for a few months get a notebook to keep track of the problems you find and fix.
If you intend to keep it for awhile get a thick notebook, (I put 5-10 on each page and I'm on page 38).
Mel
'96 Safari, (mine since '01)
mel s is offline   Reply With Quote
Old 05-10-2014, 01:52 PM   #8
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2014
Location: Whitehouse Station, NJ
Posts: 661
Have tables water heater so only runs on propane.

Took it back to dealer this morning and found a bad hose that was leaking between main valve and regulator. Had me back on the road in about 45 minutes no charge. DW was at a funeral so I backed rv into site and made all the connections solo. Big learning curve today. 😀
__________________
Randy & Ella (terrier mix rescue)
2013 Tiffin Phaeton 40QBH
2014 Ford Edge
mricet1005 is offline   Reply With Quote
Old 05-10-2014, 01:53 PM   #9
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2014
Location: Whitehouse Station, NJ
Posts: 661
Luckily we were only 30 minutes from dealer on our first trial run.
__________________
Randy & Ella (terrier mix rescue)
2013 Tiffin Phaeton 40QBH
2014 Ford Edge
mricet1005 is offline   Reply With Quote
Old 05-10-2014, 01:55 PM   #10
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2014
Location: Whitehouse Station, NJ
Posts: 661
Tankless water heater, not tables water heater. Damn autocorrect on tablet!
__________________
Randy & Ella (terrier mix rescue)
2013 Tiffin Phaeton 40QBH
2014 Ford Edge
mricet1005 is offline   Reply With Quote
Old 05-10-2014, 04:24 PM   #11
Senior Member
 
garykk's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Southern NM
Posts: 1,688
Quote:
Originally Posted by mricet1005 View Post
Tankless water heater, not tables water heater. Damn autocorrect on tablet!
After some really good mess ups with auto correct, I shut mine off
__________________

__________________
2018 Allegro Bus 37AP
2014 Phaeton 40 QBH (sold)
2018 Jeep Recon
garykk is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Okay ... I SOLVED THE AUTO PARK BRAKE PROBLEM! JerryPeck Workhorse and Chevrolet Chassis Motorhome Forum 167 05-29-2019 09:37 PM
Possible new TS owner Sirmowsalot Travel Supreme Owner's Forum 22 04-14-2014 03:12 PM
04 Essex gen starter problem ryankaty Newmar Owner's Forum 1 03-18-2014 08:10 AM
Fridge Problem Rossi6998 Winnebago Industries Owner's Forum 22 01-10-2014 08:02 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.