RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-31-2014, 11:48 PM   #1
Senior Member
 
billdreamlv's Avatar
 
Tiffin Owners Club
Join Date: Jul 2014
Posts: 487
Newbee with an electrical story

We purchased our 2006 Allegro Bus from a reputable dealer and we decided to take our first trip up to the Oregon coast. All went well and then we started to have voltage problems. Since I was new to RVing and this was my first MH I didn't have a clue as to what to expect from the generator/batteries/hookup power. I didn't know how it all worked together. So when we received a low DC message on the Refrigerator we would turn on the generator and nothing would happen. I was looking at 10.2 volts in the house and that just didn't seem right. So I purchased new batteries and thought that would fix the problem. It didn't. Then coming home from Reno we noticed that the CO detector would go on and off and the refrigerator died. On the way home my wife read the technical aspects of the refrigerator and we found out that the control panel quits at 9.5 volts. The next morning I tested the house power and it was down to 8.22 volts. I measured the batteries in the battery compartment, they had 12.6 volts. Bottom line, there was a loose battery cable behind the panel that connects the battery cables from the batteries. There is a bus bar behind the panel and one of the nuts holding the battery cable on the bus bar was so loose it took me about 7 or 8 complete turns to get it tight. I turned the nut so many times I thought it was a stripped post. Finally it tightened up and I had 12.6 volt in the house again. Wow. It must have been that way since the factory. Needless to say my first impression was not a good one for my MH. I couldn't figure out how all of this 12v stuff worked, but since I fixed the problem I am enjoying the coach very much. That said, is there a club in Las Vegas? We would like to join and get going with our new Bus.

Bill and Mary

2006 Allegro Bus
__________________

billdreamlv is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-31-2014, 11:56 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,515
Glad to hear that you were able to fix up you problems . To bad that you bought batteries though.

Hope you continue to enjoy your RV and have many safe and trouble free trips.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-01-2014, 12:00 AM   #3
RVM#87 / Senior Member
 
DieselTech39's Avatar


 
Solo Rvers Club
Join Date: Jul 2014
Location: Ham Lake, MN
Posts: 3,038


Glad you're aboard. SOrry to hear you had problems. Good to hear you got it fixed. Enjoy your adventures and be safe.
__________________
Have a wonderful day!
Ken (RVM 87)
FT DP Wanna B The journey is the destination!
Retired & perfecting procrastination!
DieselTech39 is offline   Reply With Quote
Old 08-01-2014, 12:18 AM   #4
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 20,430

Good luck with finding a solution to your situation.
__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My RV Upgrades
JohnRR is offline   Reply With Quote
Reply

Tags
electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
More Electrical Issues on 2014 44B Aspire Diesel Diva Entegra Owner's Forum 7 07-23-2014 12:07 PM
2013 Lazy Days / Anthem War Story Katsuey Entegra Owner's Forum 17 07-04-2014 06:45 AM
DC Electrical Issue Jchet Class A Motorhome Discussions 5 05-07-2014 09:53 PM
A/C electrical problem. Bwainsp Class A Motorhome Discussions 4 11-01-2013 01:58 PM
American Coach: Revolution LE electrical cerecdoc Fleetwood Owner's Forum 9 07-20-2013 01:10 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×