RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-25-2019, 10:51 AM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 12
Question Problem with Atwood levelegs system

I think the control panel needs to be replaced, but I can't find any information on line. Any idea if that can be replaced or fixed? I bought my unit (2005
allegro 32BA) 6 years ago, leveling system has been hard to turn on most of the time. Now it won't turn on at all.
__________________

SLVrver is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-25-2019, 12:15 PM   #2
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 3,611
Sorry but your system is out of production and no longer supported. Jacks can be found but electronic components are really hard to come by. You might want to start looking at HWH as a replacement.
__________________

__________________
Roger & Mary
2017 Winnebago Navion 24V
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Old 07-25-2019, 04:48 PM   #3
Member
 
Join Date: Dec 2018
Posts: 87
You can often find them available on Ebay.
__________________
"Revconguy" (First MH was a Revcon)
-2007 Tiffiin Phaeton 40-QDH pusher
-1998 Winnebago 32-WQ gasser
Revconguy is offline   Reply With Quote
Old 07-26-2019, 03:49 PM   #4
Member
 
gabeears's Avatar
 
Join Date: Mar 2012
Posts: 70
Do you have the electric jacks? If so, I have a control panel that might work. Greg
gabeears is offline   Reply With Quote
Old 08-09-2019, 03:29 PM   #5
Junior Member
 
Join Date: Jul 2019
Posts: 1
I have a 2006 Allegro bay 37 QDB and the electronic control board burned up do to large draw from one motor and there is not fuse in series with each motor, just the complete feed fuse. So any way I have the unit upgraded to the newer system. Complete change out of all components by Tiffin at Red bay by there service department. Best pricing at that time. I have heard that Tiffin no longer does service work only Warranty work. Maybe some outside service in the Red Bay area could do the work. Good luck.
jackgeorge is offline   Reply With Quote
Old 08-18-2019, 12:37 AM   #6
Senior Member
 
riverat's Avatar
 
Tiffin Owners Club
Join Date: Jul 2016
Location: Alabama
Posts: 132
Quote:
Originally Posted by gabeears View Post
Do you have the electric jacks? If so, I have a control panel that might work. Greg
I'm interested if you still have the controller.
__________________
2001 Thor Four Winds Class C (sold)
2005 Tiffin Allegro Bay 34XB (gently used)
riverat is offline   Reply With Quote
Old 08-18-2019, 08:25 AM   #7
Junior Member
 
Join Date: Mar 2015
Posts: 1
I have had issues with these jacks but a few years ago I pulled the jacks off and took the motors off them and had the bushings replaced with bearings and they have worked great since then. I have also got relays for the control panel and replaced ones that burned out. This was on a 2008 phaeton
__________________

Garry D is offline   Reply With Quote
Reply

Tags
atwood, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood levelers -levelegs system not working on Fleetwood Storm 31A Janebob1 RV Systems & Appliances 10 02-06-2017 11:11 AM
Atwood Levelegs system DandS Newmar Owner's Forum 33 09-17-2012 09:18 PM
Atwood Levelegs Electric Jack System Failed - UPDATE GerryB54 Fleetwood Owner's Forum 18 06-25-2009 08:26 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×