RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-17-2014, 12:40 PM   #1
Member
 
Join Date: Jul 2014
Location: E. Wenatchee Wa.
Posts: 33
problem with headlights

Howdy, we have a 1996 alegro 40 ft pusher and I've been having problems with my headlights going off and on. Clearance lights stay steady as well as dash lights, problem is just headlights randomly flashing . I changed out the switch and nothing changed. I'm thinking the problem is a loose wire in the steering column. Anyone experienced a problem like this? I try not to drive at night but got caught out because of construction, had a police follow me home (had flashers on and driving with my spotlight) he followed me to my parking spot then went on by shaking his head, ptl!
__________________

__________________
1996 Allegro F/L chassis, 8.3 cummins, occasionally pushed by a model A, Steve J.
model a guy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-17-2014, 03:30 PM   #2
Senior Member
 
Pigman1's Avatar
 
Join Date: Feb 2008
Posts: 2,976
It sounds like you have an short in the headlight system. Headlights are protected by a circuit breaker that automatically resets if the short is intermittent or when the breaker cools enough to reset so you don't lose lights completely in the dark. I'd get an ohmmeter and start looking for a wire short from the lights back. First question would be "does it happen on both high and low beams?",
__________________

__________________
Pigman
2013 Tiffin Allegro Bus 43QGP
2011 Chevy Silverado 1500 Toad
Pigman1 is offline   Reply With Quote
Old 09-18-2014, 09:35 AM   #3
Member
 
Join Date: Jul 2014
Location: E. Wenatchee Wa.
Posts: 33
Good mornin' yes it does happen in both high and low beams, one time I turned on high beams and lights went clear out (just headlights not running lights) switched back to low beam and were on for a moment then started flickering, they flash too erratic to be a breaker. My coach is old enuff that fuses and relays (don't seem to have any breakers) are located in a variety of places, most are under dash and accessed thru a small door that looks like a glove box, I have found relays for both right and left side headlights. I don't get any flicker by wiggling wires coming out of this relay block or wiggling wires coming out of light switch, but haven't got into steering column. Hoping someone might have had this problem and give me some advise on accessing the column. I have a freightliner chassis.
__________________
1996 Allegro F/L chassis, 8.3 cummins, occasionally pushed by a model A, Steve J.
model a guy is offline   Reply With Quote
Reply

Tags
lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Okay ... I SOLVED THE AUTO PARK BRAKE PROBLEM! JerryPeck Workhorse and Chevrolet Chassis Motorhome Forum 167 05-29-2019 09:37 PM
Jeep vacuum booster problem, Brake Buddy Rvbuzz Toads and Motorhome Related Towing 17 10-05-2015 10:48 AM
Hydraulic Slide Problem Dalybill Excel Owner's Forum 5 09-06-2014 11:12 AM
Problem with Interior Thinlite ceiling Lights ratoike National RV Owner's Forum 5 07-29-2014 09:56 PM
Fridge Problem Rossi6998 Winnebago Industries Owner's Forum 22 01-10-2014 08:02 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.