RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-22-2014, 03:45 PM   #1
Junior Member
 
Join Date: May 2014
Posts: 2
Slide out won't extend

I have a 2005 Allegro Bay MH and the front lide won't extend I'm thinking maybe the circuit breakers have tripped but I can't find the reset button. This is in the front storeage compartment in front of the entry. Any ideas or where I can get better pics showing this?
Thanks.
59fliptop
__________________

59fliptop is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-22-2014, 04:32 PM   #2
Senior Member
 
trackman's Avatar
 
Join Date: Oct 2011
Posts: 1,136
I believe that is 12 volt so you need to look at blown fuses
__________________

trackman is offline   Reply With Quote
Old 05-22-2014, 07:36 PM   #3
Senior Member
 
jlabit's Avatar
 
Join Date: Jan 2014
Location: Pensacola, Florida
Posts: 180
I made the mistake of attempting to extend the slides with the engine running. My Thor Hurricane has a lockout switch that disengages the slides when the engine is running. Probably not your issue, but it was a mistake I made on my last trip. I am very new to all of this.
__________________
Jim & Judy & Bella (Black Lab) & Sunny (Retriever)
2010 Thor Hurricane 33T
TOAD 2014 Ford Focus LE
jlabit is offline   Reply With Quote
Old 05-22-2014, 07:58 PM   #4
Senior Member
 
jfran304's Avatar
 
Tiffin Owners Club
Workhorse Chassis Owner
Join Date: Oct 2009
Location: Warner Robins, GA
Posts: 2,613
Quote:
Originally Posted by 59fliptop View Post
I have a 2005 Allegro Bay MH and the front lide won't extend I'm thinking maybe the circuit breakers have tripped but I can't find the reset button. This is in the front storeage compartment in front of the entry. Any ideas or where I can get better pics showing this?
Thanks.
59fliptop
Check out the Tiffin RV Network. In the RV Tech Library section you will find a lot of information and schematics.

Tiffin RV Network

Good Luck
Jon
__________________
Jon & Sue Francis (Retired U.S.A.F.)
Lil Girl-Rescued, Abby Rescued, Peaches Rescued
06 Allegro 35TSA Workhorse Chassis
2013 Chevy Spark Dinghy
jfran304 is offline   Reply With Quote
Old 05-22-2014, 09:32 PM   #5
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 20,241

Good luck with solving your problem.
__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 05-23-2014, 06:22 AM   #6
Member
 
Teacher's Pet's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Sep 2003
Location: On the Road
Posts: 92
Quote:
Originally Posted by 59fliptop View Post
I have a 2005 Allegro Bay MH and the front lide won't extend I'm thinking maybe the circuit breakers have tripped but I can't find the reset button. This is in the front storeage compartment in front of the entry. Any ideas or where I can get better pics showing this?
Thanks.
59fliptop

If it is the driver's side electric slide, check to see if the motor is dis-engaged. The motor has a rubber booted lever on one end that flips up and down that dis-connects it from the drive line.
__________________
Terry (He) & Dale (She)
Fulltimers since 9/'05
2006 Phaeton, 40' QSH, 350 Cat
Teacher's Pet is offline   Reply With Quote
Old 05-24-2014, 03:58 PM   #7
Member
 
Join Date: Feb 2013
Posts: 30
Sounds somewhat similar to a recent experience on my 2008 Allegro Open Road (TGA34). Driver-side slide would not extend but other two worked fine. Finally tracked it down to a blown fuse on small printed-circuit board located on larger "control panel" mounted in basement compartment immediately behind the main entry door. All other fuses were OK - and Tiffen support tech knew nothing about this fuse.
HTH
jacksonmacd is offline   Reply With Quote
Old 05-25-2014, 10:16 AM   #8
Junior Member
 
Join Date: May 2014
Posts: 2
Thanks everybody for your input
59fliptop
__________________

59fliptop is offline   Reply With Quote
Reply

Tags
slide, slide out



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A New Thread on 33.2 Slide and My Experience DMBanwarth Palazzo Motorhomes 13 07-12-2014 09:20 AM
Slide out of Alignment Glen and Sal National RV Owner's Forum 10 03-03-2014 06:55 PM
Slide problems with Slide Show emcee MH-General Discussions & Problems 6 02-05-2014 05:35 PM
Slide won't extend '08 Dutchstar 4317 LonandLaura iRV2.com General Discussion 13 08-31-2013 03:09 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×