RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-12-2019, 09:53 AM   #1
Member
 
Join Date: Jul 2017
Posts: 33
Splendide Washer Problem

We have a separate Splendide Washer and Dryer setup. When my wife does a load of laundry, the washer fills up and runs for about 20 minutes. Half way into the cycle, an alarm goes off and shows the H2O fault. I've checked the hoses and drain, and everything seems to be fine. This is also done when hooked up to water, I have not tried it while just boon docking. No obstructions that I can find. Any ideas what could be going wrong?
__________________

Bagelboy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-12-2019, 11:21 AM   #2
Senior Member
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 3,511
Quote:
Originally Posted by Bagelboy View Post
We have a separate Splendide Washer and Dryer setup. When my wife does a load of laundry, the washer fills up and runs for about 20 minutes. Half way into the cycle, an alarm goes off and shows the H2O fault. I've checked the hoses and drain, and everything seems to be fine. This is also done when hooked up to water, I have not tried it while just boon docking. No obstructions that I can find. Any ideas what could be going wrong?
What type of water pressure do you have? If your pressure is low, the washer may not be filling up enough on the rinse cycle causing the water alarm.
__________________

__________________
Dan & Ro with two Rescued Boston "Terrorists" Jade & Jewel
2017 Phaeton 40IH Maroon Coral - Power Glide Chassis with IFS (05/17)
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'12 Jeep JK Wrangler Sport or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 01-12-2019, 03:23 PM   #3
Senior Member
 
simonsrf's Avatar
 
Tiffin Owners Club
Join Date: Oct 2010
Posts: 219
Quote:
Originally Posted by Bagelboy View Post
We have a separate Splendide Washer and Dryer setup. When my wife does a load of laundry, the washer fills up and runs for about 20 minutes. Half way into the cycle, an alarm goes off and shows the H2O fault. I've checked the hoses and drain, and everything seems to be fine. This is also done when hooked up to water, I have not tried it while just boon docking. No obstructions that I can find. Any ideas what could be going wrong?
While using the washer, turn the on-board water pump on at the same time, should take care of your problem.
__________________
2012 Tiffin Phaeton 36 GH
2013 GMC Sierra SLT 4x4 (flat towed)
Honda Pioneer 500 (UTV)
simonsrf is offline   Reply With Quote
Old 01-12-2019, 04:31 PM   #4
Member
 
Join Date: Jul 2017
Posts: 33
I just pulled in to florida and I won't be RVing for the next 10 days. But I'll try turning on the water pump while also doing laundry and see if this helps, thanks.
Bagelboy is offline   Reply With Quote
Old 01-12-2019, 06:08 PM   #5
Senior Member
 
garykk's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Southern NM
Posts: 1,695
I think there may be screens on the inlets of the washer.
garykk is offline   Reply With Quote
Old 01-13-2019, 06:49 AM   #6
Member
 
Join Date: Jul 2017
Posts: 33
Boy oh boy, do I hate the idea of possibly pulling out the washer and dryer on my own if that's true.
Bagelboy is offline   Reply With Quote
Old 01-13-2019, 03:21 PM   #7
Senior Member
 
garykk's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Southern NM
Posts: 1,695
We got the same code one time on our Phaeton. I called the maker help line. Turned out to be one of those 1/2 turn shut off valves had been rubbing on some woodwork and turned itself off
__________________
2018 Allegro Bus 37AP
2014 Phaeton 40 QBH (sold)
2018 Jeep Recon
garykk is offline   Reply With Quote
Old 01-14-2019, 01:27 PM   #8
Member
 
Join Date: Jul 2017
Posts: 33
I checked the shutoffs. They're fine. I'll have to check the water pressure that's coming in. I'm not RVing again til next week, so I cant really check anything out til I hit the road again
Bagelboy is offline   Reply With Quote
Old 01-14-2019, 02:46 PM   #9
Senior Member
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 3,511
Quote:
Originally Posted by Bagelboy View Post
Boy oh boy, do I hate the idea of possibly pulling out the washer and dryer on my own if that's true.
You haven't said what model coach you have, but some of the models have an access panel or hole to reach the hose bib connections behind the washer.
__________________
Dan & Ro with two Rescued Boston "Terrorists" Jade & Jewel
2017 Phaeton 40IH Maroon Coral - Power Glide Chassis with IFS (05/17)
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'12 Jeep JK Wrangler Sport or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 01-15-2019, 07:17 AM   #10
Member
 
Join Date: Jul 2017
Posts: 33
2019 34PA Allegro Open Road
__________________

Bagelboy is offline   Reply With Quote
Reply

Tags
problem, splendide



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Splendide Combo Washer/Dryer problem Knightly RV Systems & Appliances 14 12-29-2015 09:00 PM
Problem with Splendide combo washer and Dryer 2000S boltdave RV Systems & Appliances 4 01-02-2015 09:00 PM
"heads up" broken water hose Splendide washer Jcous Winnebago Industries Owner's Forum 15 02-24-2009 06:52 PM
Karibe (Splendide) Washer/Dryer Combo Door Will Not Open Tom Norman MH-General Discussions & Problems 10 01-10-2009 06:34 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.