RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-04-2018, 01:56 PM   #1
Junior Member
 
Join Date: Mar 2017
Location: Marquette Michigan.
Posts: 15
Thermostat gone bad

My bedroom thermostat shows 48 degrees while itís really about 87 degrees in the bedroom. Front thermostat seems to be working fine. Anybody have an idea whatís up. I have tried to set numerous times no luck, any help would be appreciated.

Ron & Kim
__________________

Concord1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-04-2018, 02:27 PM   #2
Member
 
Join Date: Jul 2015
Location: College Station TX
Posts: 49
Same thing with mine but was the front thermostat.

Dealer will be looking at it mid week.

2014 allegro bus 37AP
__________________

Rodzent is offline   Reply With Quote
Old 11-04-2018, 02:55 PM   #3
Senior Member
 
curtsr's Avatar
 
Tiffin Owners Club
Join Date: Nov 2014
Posts: 312
Quote:
Originally Posted by Concord1 View Post
My bedroom thermostat shows 48 degrees while itís really about 87 degrees in the bedroom. Front thermostat seems to be working fine. Anybody have an idea whatís up. I have tried to set numerous times no luck, any help would be appreciated.

Ron & Kim
Check for a loose wire on the remote sensor on the ceiling in the bedroom.
curtsr is offline   Reply With Quote
Old 11-05-2018, 01:16 PM   #4
Senior Member
 
KennyGolub's Avatar
 
Entegra Owners Club
Join Date: Jul 2011
Location: Medina, Ohio
Posts: 805
Send a message via MSN to KennyGolub
When our thermostat acted up, it turned out to be the temperatures sensor.


-
__________________
Ken & Laurie Retired Cleveland PD
North in summer, Home in Silver Springs, FL in the Winter
2019 Entegra Aspire 44W -2018 Jeep Wrangler JL TOAD
KennyGolub is online now   Reply With Quote
Old 11-05-2018, 03:50 PM   #5
Junior Member
 
Join Date: Mar 2017
Location: Marquette Michigan.
Posts: 15
Got it!

Turned out to be loose wire as one member suggested, love this site that for all your help!!
Concord1 is offline   Reply With Quote
Old 11-05-2018, 03:55 PM   #6
Senior Member
 
curtsr's Avatar
 
Tiffin Owners Club
Join Date: Nov 2014
Posts: 312
Quote:
Originally Posted by Concord1 View Post
Turned out to be loose wire as one member suggested, love this site that for all your help!!
__________________

curtsr is offline   Reply With Quote
Reply

Tags
thermostat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Good SAM...Bad Sam Bad Bad Bad! STLNLUV iRV2.com General Discussion 43 12-17-2018 07:49 AM
Airxcel thermostat gone wild ! deputybubba MH-General Discussions & Problems 10 07-31-2018 02:06 AM
Has my Thermostat gone bad? JFXG RV Systems & Appliances 1 11-10-2017 12:02 PM
Bad, bad, bad - bad vibrations.... Doc Vegas Ford Motorhome Chassis Forum 21 11-30-2014 05:56 PM
Thermostat gone bad? Belgique Winnebago Industries Owner's Forum 2 02-17-2007 04:12 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.