RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-21-2018, 04:35 PM   #1
Junior Member
 
Join Date: Dec 2017
Location: Palm Coast, FL
Posts: 29
Windshield wipers not working

I have a 2008 Allegro Bay 37 QDB Diesel, with windshield wipers not working. They work only when I press for intermittent wipes.
I think it is the fuse but unable to find fuses. I have looked by driver and under front dash.
Can anyone please let me know where fuses are located? Owners manual was not much help.
__________________

razman95 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-21-2018, 04:39 PM   #2
Senior Member
 
Mr_D's Avatar
 
Country Coach Owners Club
Winnebago Owners Club
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 35,965
Smart wheel?
__________________

__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 Jeep JKU
Mr_D is offline   Reply With Quote
Old 03-22-2018, 08:02 AM   #3
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 3,544
The fuses are in the compartment that is below the driver's seat. However, you have two knobs - the inner small one which you turn to select wiper speed and a large flat one that you select intermittent wiper speeds. If you are turning the small knob and the wipers are going, it is probably the switch. If the fuse was bad, the wipers wouldn't work when you pressed down on the wiper control.
__________________
Roger & Mary
2017 Winnebago Navion 24V
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Old 06-06-2018, 07:34 AM   #4
Junior Member
 
Join Date: May 2009
Location: Washoe Valley, NV
Posts: 6
Hello Razzman- my wiper controls are doing the same thing. Push the button in the middle of the ring and it will wipe one time then stop. The round circle does nothing. It happened once before and the freightliner shop said it was a fuse. But I did not ask where the fuse is. Roger and Mark say it is in the fuse panel in the compartment below the drivers seat I'm looking but have not located it yet.
Thanks
Rick Rinehart
Washoe Valley, NV

2014 Allegro Red 33
2014 Honda CR-V
RickRinehart is offline   Reply With Quote
Old 06-10-2018, 07:11 AM   #5
Senior Member
 
danf7's Avatar
 
Tiffin Owners Club
Nor'easters Club
Join Date: Jan 2009
Location: ma
Posts: 407
Turn the inner knob. The outer one just sets speed.
Dan
__________________
Dan 2008 Allegro 32 BA FRED, Honda Fit
There are 10 types of people in this world. Those who know binary, and those who don't.
danf7 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wipers Not Working HDBiker Dave Newmar Owner's Forum 4 10-16-2018 09:54 AM
windshield wipers still not working kayla44 Tiffin Owner's Forum 5 06-25-2016 06:26 PM
Windshield wipers stopped in the "up" position, not working!!! Roamin Mike RV Systems & Appliances 1 05-27-2016 04:58 PM
'12 F53 windshield wipers not working H3OHIO Ford Motorhome Chassis Forum 2 11-22-2014 03:33 PM
Windshield Wipers Not Working standardbob National RV Owner's Forum 4 06-30-2012 07:09 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.