RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-03-2017, 08:36 AM   #1
Member
 
nehmia's Avatar
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Mar 2016
Posts: 53
'16 Bounder - Gauge Cluster, cockpit switches, and headlight LED accent not working

I'm at the Alvarado, TX REV service center for some warranty repairs. While here, one morning when I took the RV in all the cockpit gauges and rocker switches with back lights were not working. Also noticed, the LEDs that surround the headlamps were not lighting up. running lights and headlights worked however.

I checked three 10A fuses under the cockpit on drivers side that are for the instrument cluster, all were fine. Saw no damage to wiring under dash, all connectors good and tight. Also, yes the dimmer knob is turned up, even when you go to 100% on the knob, I can hear a little relay click. No idea what it's supposed to do, never had an over head light come on in the past. Not sure where else to look, anyone know what would cause all of this lighting to go out at once?

Of note, I do have a 5Star tune, been running it for a month now. Wondering if it has anything to do with it..?

Reason I am here asking is the REV service center is very hands off with anything to do with the chassis, that's ford only. I pushed back on it but I'm not holding my breath, so I'm here.
__________________

__________________
2016 Fleetwood Bounder 33C | 5Star | TM A1A | Saf-T-Plus | NSA ReadyBrute Elite | 2010 Jeep Wrangler JK Rubicon
nehmia is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-03-2017, 08:55 AM   #2
Senior Member
 
computerguy's Avatar
 
Join Date: Jul 2010
Location: FT on the Road
Posts: 2,581
I would check the ground buss bars. There is one under the dash by the drivers side. I believe it is on the firewall up pretty high. There is one on the opposite side too if I recall in the engine compartment.
I checked mine and ALL the nuts were loose.
__________________

computerguy is offline   Reply With Quote
Old 02-03-2017, 08:59 AM   #3
Member
 
nehmia's Avatar
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Mar 2016
Posts: 53
That's a good tip, I should go around and look for the red paint on the ground connections and ensure they are tight.

So, did not expect a fast turn around however there is a fuse in the engine compartment that was blown apparently. Will need to find out what fuse location it was. Got push back on it but they found it. Kudos to REV.

Quick fix/turn around, but I searched this sub-forum and couldn't find much on dash lighting going out so at least this is here now for future reference. I'll update with which fuse it was if someone else doesn't first.

The fuse location is the power distribution box in the engine compartment. It is a 20A fuse, in slot 6.

Here is the owners manual for reference. Page 64.
__________________
2016 Fleetwood Bounder 33C | 5Star | TM A1A | Saf-T-Plus | NSA ReadyBrute Elite | 2010 Jeep Wrangler JK Rubicon
nehmia is offline   Reply With Quote
Reply

Tags
bounder, led, light, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LED Hutch accent light. RLWoud Entegra Owner's Forum 2 03-10-2015 06:26 AM
cockpit Instrument switches recaffey Monaco Owner's Forum 5 10-16-2012 08:03 AM
Dash Fans in Cockpit Not Working on 2007 35A Pace Arrow jaynit Class A Motorhome Discussions 8 08-25-2012 09:38 PM
cockpit fans not working bobsshop Class A Motorhome Discussions 4 10-09-2011 02:29 PM
Fuel Gauge & Volt Gauge not working Deerhunter Freightliner Motorhome Chassis Forum 9 07-20-2010 03:22 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×