RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-24-2015, 07:42 PM   #1
Member
 
Join Date: Sep 2009
Posts: 74
2005 Fleetwood Revolution Zone 2 AC not working

The blower is working but no cold air. Zone 1 AC is working fine. Any one have any thoughts? I'm hoping this isn't major and maybe a simple fix I can handle.
__________________

BINGHAMD is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-24-2015, 08:08 PM   #2
Senior Member
 
krivanj's Avatar


 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Oct 2009
Location: Fort Pierce, FL
Posts: 742
Make sure your thermostat is not set on fan only... Easy to do if you bump,the wrong button. It should say cool on the thermostat.
__________________

__________________
Revolution LE 38X C9 Cat
2011 Scion TC toad
krivanj is offline   Reply With Quote
Old 05-24-2015, 08:20 PM   #3
Member
 
Join Date: Sep 2009
Posts: 74
Quote:
Originally Posted by krivanj View Post
Make sure your thermostat is not set on fan only... Easy to do if you bump,the wrong button. It should say cool on the thermostat.
I was hoping that was the problem initially, but that's not it. It is easy to do as you said. Thanks for the response!
BINGHAMD is offline   Reply With Quote
Old 05-24-2015, 10:38 PM   #4
Senior Member
 
Ford Super Duty Owner
Join Date: Apr 2012
Location: Austin, TX
Posts: 1,885
Quote:
Originally Posted by BINGHAMD View Post
The blower is working but no cold air. Zone 1 AC is working fine. Any one have any thoughts? I'm hoping this isn't major and maybe a simple fix I can handle.
Well, that means both units have power, so that's good. My next guess would be starting capacitor for the compressor. Sometimes the capacitors go bad and you can see it, but often you cant.... You could try switching capacitors and see if that changes things... There is likely a means to test them too.

What model are they?
cb1000rider is offline   Reply With Quote
Reply

Tags
fleetwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fleetwood Revolution LE dgarven Class A Motorhome Discussions 29 11-30-2014 10:42 AM
Fleetwood Revolution Ron Goshorn Class A Motorhome Discussions 5 10-31-2014 07:36 AM
110 power issues - 2002 Fleetwood revolution ksk5568 RV Systems & Appliances 1 08-10-2014 03:39 PM
Fleetwood Revolution rear camera okiegirl2u Class A Motorhome Discussions 11 07-31-2014 06:13 PM
Fleetwood Revolution 40 LE blackwater problem Mickey123 Fleetwood Owner's Forum 3 06-01-2013 04:31 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.