RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-14-2014, 10:18 PM   #1
Junior Member
 
Join Date: Oct 2014
Location: Ca
Posts: 8
98 American Eagle Illumination Help

i could use some help, especially from owners of American Eagles. I have a situation which I don't think is normal. I have a few questions but would like to get my illumination problem fixed as I have an outing coming up.

The controls to some buttons on control panel near the armrest don't light when I turn on my headlights. The transmission gear is displayed but the cruise control, ICC and PAC indicator lights aren't displayed when headlights are on. Is this normal? The same goes for the spotlight controls. I have removed panel to inspect and don't see a bulb. I did discover a loose wire which is powered when turning on headlights. Don't see where it would go. It's grouped with cruise control wiring. The only spot I see where it may connect is to transmission controls. Appreciate any help anyone can provide.

Thank you in advance.
__________________

Eagle98 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-15-2014, 12:49 AM   #2
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 20,651

Good luck with a solution.
__________________

__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 10-15-2014, 09:04 AM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar
 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 40,396
Welcome to IRV2! It's great to have you join the gang!

Sorry I can't help with your questions. Enjoy the forum!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 10-15-2014, 09:49 AM   #4
Senior Member
 
Cat320's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Mar 2011
Posts: 5,516
Call AC, they are very helpful...have your VIN handy: 800-435-7345.
__________________
2014 American Eagle 45T
DD 13, 500 HP
Pulling a Honda CRV
Cat320 is offline   Reply With Quote
Old 10-16-2014, 12:07 AM   #5
Junior Member
 
Join Date: Oct 2014
Location: Ca
Posts: 8
Thank you for welcoming me. It's welcoming just receiving replies.

Cat320 Thanks for suggesting AC. I too think they are helpful but they were unable to assist me on this question other than sending me a complicated schematic. I'm sure another member will know if the side controls are supposed to illuminate when activating the headlights.


Thanks to all
Eagle98 is offline   Reply With Quote
Old 10-16-2014, 05:41 PM   #6
Senior Member
 
Join Date: May 2010
Location: N.E. Florida
Posts: 1,085
Quote:
Originally Posted by Eagle98 View Post
i could use some help, especially from owners of American Eagles. I have a situation which I don't think is normal. I have a few questions but would like to get my illumination problem fixed as I have an outing coming up.

The controls to some buttons on control panel near the armrest don't light when I turn on my headlights. The transmission gear is displayed but the cruise control, ICC and PAC indicator lights aren't displayed when headlights are on. Is this normal? The same goes for the spotlight controls. I have removed panel to inspect and don't see a bulb. I did discover a loose wire which is powered when turning on headlights. Don't see where it would go. It's grouped with cruise control wiring. The only spot I see where it may connect is to transmission controls. Appreciate any help anyone can provide.

Thank you in advance.
On my 98 none of the items you listed illuminate with the headlights turned on. Just the rocker switch array and the instrument panel gauges will illuminate for nightime operation.

You will get accustomed to each switch location after some hours behind the wheel of your 98. After almost 6 years of operation, I never have to look to hit the switch I am seeking.
__________________
DaveS
1998 American Eagle 40EVS
FormerBoater is offline   Reply With Quote
Old 10-16-2014, 07:24 PM   #7
Senior Member
 
Country Coach Owners Club
Retired Fire Service RVer's
Join Date: Feb 2013
Location: Ocala, Florida
Posts: 6,295
Welcome and glad to meet you!
__________________
FMCA #F431170, GS #822128658, Escapees SKP #112655
2012 Airstream Mercedes Interstate Class B
[SIGPIC][/SIGPIC]
Medico is offline   Reply With Quote
Old 10-16-2014, 07:35 PM   #8
RVM#87 / Senior Member
 
DieselTech39's Avatar


 
Solo Rvers Club
Join Date: Jul 2014
Location: Ham Lake, MN
Posts: 3,038


Glad you're aboard. Best of luck on a solution to your question. Enjoy your adventures and be safe.
__________________
Have a wonderful day!
Ken (RVM 87)
FT DP Wanna B The journey is the destination!
Retired & perfecting procrastination!
DieselTech39 is offline   Reply With Quote
Old 10-16-2014, 11:01 PM   #9
New to the RV World
 
GlennLever's Avatar
 
Vintage RV Owners Club
American Coach Owners Club
Join Date: Aug 2013
Location: Rochester, NY
Posts: 3,092
Is this the console you are talking about?



This is inside my American Dream



The loose wire I suspect goes to one of the tabs on the on/off button for the cruise control. That button should light when the cruise is on.

The spot light area does not light at all, the exhaust brake indicator lights when the exhaust brake is on, the on / off button for the cruise lights when the cruise control functions are active. None of these lights work in conjunction with the head light switch.

Lets see some pictures of your Eagle

You can post them here
Amer. Dream, Tradition, Eagle, Heritage,Allegiance,Revolution owners reference list

Amer. Dream, Tradition, Eagle, Heritage,Allegiance,Revolution owners reference list
__________________
See projects on my 1997 America Dream here, Index to the projects is in the first post.
http://www.irv2.com/forums/f107/proj...am-174380.html

[SIGPIC][/SIGPIC]
GlennLever is offline   Reply With Quote
Old 10-17-2014, 07:51 AM   #10
Senior Member
 
Join Date: May 2010
Location: N.E. Florida
Posts: 1,085
Glenn is spot on, I forgot that the cruise button illuminates when cruise is engaged, likewise the Pac-brake red rocker illluminates when engaged.

Pac-brake will also be displayed on your instrument panel at top right when engaged.

Let's see some pics!
__________________
DaveS
1998 American Eagle 40EVS
FormerBoater is offline   Reply With Quote
Old 10-19-2014, 11:31 PM   #11
Junior Member
 
Join Date: Oct 2014
Location: Ca
Posts: 8
Ticket History
John Romo (Client) Posted On: 18 October 2014 01:51 PM

Thank you for the great information Glenn. The photograph of the console you posted is the area I have concern with. From the posts it appears it's normal some of the switches are not lit when activating the headlights. My PAC brake switch does illuminate when it's activated. My cruise control does not. The transmission controls do and as you stated my spotlight controls don't light up at all.

I did unplug the the cruise control harness and did not see a plug in which was clearly missing a wire. The only thing I can figure is the diode went out.

Here are some photos and a close up of the loose wire.

Well,not sure what's going to turn up with photos. I'm new to this.

I also apologize for the late response. Apparently I posted in the wrong area.

Thanks for everyone's help!
Eagle98 is offline   Reply With Quote
Old 10-19-2014, 11:46 PM   #12
New to the RV World
 
GlennLever's Avatar
 
Vintage RV Owners Club
American Coach Owners Club
Join Date: Aug 2013
Location: Rochester, NY
Posts: 3,092
Quote:
Originally Posted by Eagle98 View Post
Ticket History
John Romo (Client) Posted On: 18 October 2014 01:51 PM

Thank you for the great information Glenn. The photograph of the console you posted is the area I have concern with. From the posts it appears it's normal some of the switches are not lit when activating the headlights. My PAC brake switch does illuminate when it's activated. My cruise control does not. The transmission controls do and as you stated my spotlight controls don't light up at all.

I did unplug the the cruise control harness and did not see a plug in which was clearly missing a wire. The only thing I can figure is the diode went out.

Here are some photos and a close up of the loose wire.

Well,not sure what's going to turn up with photos. I'm new to this.

I also apologize for the late response. Apparently I posted in the wrong area.

Thanks for everyone's help!
The wire to supply power to the cruise control button gets connected directly to a terminal on the back of the button.

The terminal on my on/off button actually broke off and the switch was replaced with an aftermarket button to fix the problem.

I have been looking for the correct button for a long time.

The salvage yard wanted $175.00 for the cruise control panel with has the correct switch in it. This is after I had just purchased a $5,800 generator from them.

I thought it was to much money to pay just to get the correct switch.

I'll keep looking
__________________
See projects on my 1997 America Dream here, Index to the projects is in the first post.
http://www.irv2.com/forums/f107/proj...am-174380.html

[SIGPIC][/SIGPIC]
GlennLever is offline   Reply With Quote
Old 10-22-2014, 04:53 PM   #13
Junior Member
 
Join Date: Oct 2014
Location: Ca
Posts: 8
Still trying to post a photo. This is a test to see if photo shows up.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	49
Size:	293.7 KB
ID:	77150  
Eagle98 is offline   Reply With Quote
Old 10-22-2014, 05:12 PM   #14
Junior Member
 
Join Date: Oct 2014
Location: Ca
Posts: 8
Now that the photo uploaded the loose wires are the black and white wires at the top of the photo.

Also attached is a photo of the cruise control switch. Is it the correct or original part?
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	55
Size:	258.7 KB
ID:	77152  
__________________

Eagle98 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×