RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-15-2015, 03:13 PM   #1
Junior Member
 
Join Date: May 2015
Posts: 5
Discovery leveling jacks

My 2000 Discovery jacks will not go down. I am new to the RV world.
__________________

oilcap777 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-15-2015, 05:58 PM   #2
Senior Member
 
Join Date: Sep 2014
Location: Newcastle West, Ireland
Posts: 393
What do you want them to go down on?
Seriously now, have you got the PRNDL in P? Have you got the park brake on? Have you got the ignition switch on? Do you need the engine running to run them down?
__________________

__________________
'98 Southwind 34L, too many cameras, old hat, young heart.
May the light be with you.
Mentor is offline   Reply With Quote
Old 05-15-2015, 11:58 PM   #3
Senior Member
 
stink's Avatar
 
Join Date: Apr 2012
Posts: 1,414
Trans in neutral, prk brake set and engine running on my coach I press power button on jack panel. If the green light does not illuminate you may have a power problem to the panel. I would call fleetwood and ask.
__________________
Dave and Laura & two cats
02 Discovery with Accord toad
retired auto rv tech and teacher, wife rt nurse
stink is offline   Reply With Quote
Old 05-22-2015, 08:09 PM   #4
Junior Member
 
rreeves's Avatar
 
Join Date: Jan 2014
Location: Gladewater, TX
Posts: 4
I have a 2000 Discovery... And have had some issues with the jacks along with lots of other systems My Discovery has provided lots of enjoyment but not without quite a bit of tinkering. The powergear jacks used on my Discovery are not unique to the coach and seem to be pretty commonly used.

The key must be on and the tranny should be in neutral with the parking brake on. Doesn't matter if the engine is actually running or not. Does the control panel light up when you push the on button? If not, check for a fuse or wiring issue.

If it lights up and you can hear the motor run when pressing any of the down buttons, then chances are the pump has sheared the gears within it. Mine did this and I had to purchase a new pump. I removed the entire assembly from the coach and cleaned and installed the new pump. I got this off ebay (Power Gear 800301 Pump Only Service Kit for Hydraulic Leveling). This is one of the more expensive fixes that I had to do to my coach (so far )

If you can't hear the pump running then there could be a wiring issue between the control panel and the pump. You will need to check the voltage back at the pump to see if it has voltage.

Hope this helps, and good luck!
rreeves is offline   Reply With Quote
Old 05-23-2015, 07:58 AM   #5
Junior Member
 
Join Date: May 2015
Posts: 5
That does help and I appreciate that. I think I have narrowed it down to the solenoid on top of the pump. Found instruction manual online this morning, tells me how to test for that by running a 12V jumper to positive terminal. Thanks for the input, believe I will be checking eBay.
oilcap777 is offline   Reply With Quote
Old 05-23-2015, 08:06 AM   #6
Member
 
DBTulsa's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: May 2014
Posts: 84
Had this happen on our 2009 excursion, our wouldn't retract. Found a post on this forum saying to check the fluid in the pump canister. It was low, I added more fluid and then the system worked.
__________________

__________________
Don and Denise, 2 boys, 2 dogs
2009 FW Excursion 40X, Toad - 2014 Ford Explorer
Blue OX Alpha and Patriot Brake, Weber Q
DBTulsa is offline   Reply With Quote
Reply

Tags
jacks, leveling, leveling jacks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leveling Jacks 2000 Discovery lburson RV Systems & Appliances 8 06-16-2015 08:04 PM
Hydraulic leveling jacks won't pick up coach rv9apilot Monaco Owner's Forum 9 04-23-2015 07:18 PM
1990 Pace Arrow 34' leveling jacks will not work Kfeeback Fleetwood Owner's Forum 1 08-11-2014 01:03 PM
Newbie Question on Leveling Jacks Frankie Z RV Systems & Appliances 5 04-30-2014 06:16 PM
Phantom Leveling Jacks JFNM Fleetwood Owner's Forum 17 03-08-2014 02:27 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.