RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-06-2019, 07:17 PM   #1
Member
 
Goebs's Avatar
 
Join Date: Mar 2011
Location: Libertyville Il.
Posts: 34
Generator wont start after winter storage

We stored out new to us 2008 Excursion for the winter and dewinterezed it. Everything jumped to life and had no issues besides the sprayer on the faucet getting tired and slowly leaking..

Then I went to start the generator and nothing. There is a faint click outside but now a red blinking light on the interior upper panel. The red light is on the system that starts the generator if batteries are down and unplugged. Forgot the name of that system but can look.

Batteries read 13.4 as I recall on the panel. The house batteries were low in water. I filled them but may have done damage by keeping the coach plugged in all winter and letting water get too low.

I was going to just go get four fresh house batteries but wasnít sure that was the cause. We didnít use the inverter power but while driving, all tvís were getting power, microwave was ready to go and shower time.

Made me think the batteries may be fine and the generator was a separate issue.

Any advice on what to check and or test to determine best path to get things going or should I get in line at a service shop and let the professionals do their thing?

I am always interested in learning anything I can on the coach so advice would be great.

Thanks in advance!

Goebs
__________________

__________________
2008 Fleetwood Excursion 40x
Goebs is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-06-2019, 07:26 PM   #2
Senior Member
 
Join Date: Jan 2016
Posts: 487
How long did you hold the start button down? Try holding it down for 15-30 seconds and see if it starts. Sounds like maybe it was preheating and you didn't give it long enough.
__________________

Deep Water D is offline   Reply With Quote
Old 04-07-2019, 07:06 AM   #3
Senior Member
 
hayward3411's Avatar
 
Join Date: Feb 2015
Location: Huntingtown, MD
Posts: 617
Deep Water D gave you good info: it takes a while for the preheater to do it's thing. The clicking noise is normal, when cold outside it may take me 15-20 seconds for the generator to start.
__________________
Earl & Sharon, 2008 Fleetwood Expedition, ISB 6.7
1995 Jeep YJ/2013 Chevy Sonic
hayward3411 is offline   Reply With Quote
Old 04-07-2019, 10:18 AM   #4
Member
 
Goebs's Avatar
 
Join Date: Mar 2011
Location: Libertyville Il.
Posts: 34
Thanks so much for the quick feedback. I saw it and ran over to the coach to see if things would start up. Held button down for 10 seconds or so and it started right up.

So appreciate of the simple advice. This is our first diesel and lots to learn. Loving it though and canít wait for more trips!

Have a great day and thank you guys again!

Goebs
Goebs is offline   Reply With Quote
Reply

Tags
generator, storage, winter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator wont start and batteries wont stay charged Ladonnavegas Class A Motorhome Discussions 5 10-18-2017 10:48 AM
Can't get MH to start after long winter nap TomMiller Class A Motorhome Discussions 22 05-01-2014 01:31 PM
Onan Marquis HGJAB wont start after oil change! GAGypsy RV Systems & Appliances 2 10-05-2013 07:04 AM
Gen won't start after winter storage micki49 Cummins Engines 14 03-30-2013 04:30 PM
First start after winter ninos Caterpillar Engine Forum 7 03-22-2012 11:48 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×