RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Products Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-11-2018, 03:21 PM   #1
Senior Member
 
Geneandea's Avatar
 
Workhorse Chassis Owner
Holiday Rambler Owners Club
Join Date: Nov 2011
Posts: 135
Intellitec SEMS900 relay switch

My display on my 50 amp smart energy management system model 900 went blank. the display comes on sporadic on generator and now on 50 amp shore power it show Gen and power status blinking. I have power except for AC, the thermostat power is on but I can't make any changes (on generator or shore power). I suspect the relay switch. Location unknown.
2008 Pace arrow 38P GM
Thanks for any help
Gene
__________________

__________________
Gene and Bea
2008 Fleetwood Pace arrow , Allison 6 speed transmission 38P work horse W24 chassis 5.5 KW gas Onan Generator with 2009 Saturn vue.
Geneandea is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-11-2018, 05:03 PM   #2
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 19,372
Not sure what "relay switch" you are referring to - your coach has several of them.

Most likely the Smart EMS is just confused and needs to be reset (rebooted). Turn off the house battery disconnect (one of the "relay switches") for a minute and then turn it back on. The EMS display will probably have a meaningful read-out.
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 03-11-2018, 05:41 PM   #3
Senior Member
 
Geneandea's Avatar
 
Workhorse Chassis Owner
Holiday Rambler Owners Club
Join Date: Nov 2011
Posts: 135
Transfer switch, shore power vs. Generator. I turned off the house battery no effect on display ie did not kill the power.
__________________
Gene and Bea
2008 Fleetwood Pace arrow , Allison 6 speed transmission 38P work horse W24 chassis 5.5 KW gas Onan Generator with 2009 Saturn vue.
Geneandea is offline   Reply With Quote
Old 03-11-2018, 07:32 PM   #4
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 404
The Energy Management System is tied to the Battery Control Center. Looking at the drawings for our coach, there are 2 circuit breakers located inside the BCC lower left side with red wires. These 2 circuit breakers are connected to the 12 vdc, 12 spade automotive type fuses in another box- EMS fuse box and mounted next to the 125V AC circuit breaker panel (Load Center). From there these control the A/C units, LP gas furnaces and the thermostat control box.

Regarding the thermostat not working, most likely tied to the EMS problem but I had a problem that was solved by pulling off the cover, removed the ribbon cable, spray contact cleaner into the connector and the slide switch that controls the heat and air. Hope this helps.
__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Old 03-11-2018, 09:51 PM   #5
Senior Member
 
Geneandea's Avatar
 
Workhorse Chassis Owner
Holiday Rambler Owners Club
Join Date: Nov 2011
Posts: 135
I pulled the fuse for EMS and the thermostat. It cleared the problem for both. I had tried the house battery disconnect but had no effect.
__________________
Gene and Bea
2008 Fleetwood Pace arrow , Allison 6 speed transmission 38P work horse W24 chassis 5.5 KW gas Onan Generator with 2009 Saturn vue.
Geneandea is offline   Reply With Quote
Old 03-12-2018, 06:36 PM   #6
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 404
Glad you fixed the problem. What fuse did you pull?
__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Old 11-16-2018, 09:22 PM   #7
Senior Member
 
Geneandea's Avatar
 
Workhorse Chassis Owner
Holiday Rambler Owners Club
Join Date: Nov 2011
Posts: 135
Update on EMS and thermostat problems.
1. I have replaced both the remote EMS panel (did not fixed the problem) and main board. My EMS issues seem to have gone away. Note the thermostat reading 00, not working going black persisted after replacing. I have recently up graded my florescent lights to LED in hopes it was the source of the problem. I haven't been out on 50 amp/camping to verify I do have a ferrite collar to go on the thermostat wires if needed.
__________________
Gene and Bea
2008 Fleetwood Pace arrow , Allison 6 speed transmission 38P work horse W24 chassis 5.5 KW gas Onan Generator with 2009 Saturn vue.
Geneandea is offline   Reply With Quote
Old 11-17-2018, 02:50 AM   #8
Senior Member
 
KF5UMC's Avatar
 
Join Date: Sep 2015
Posts: 404
Have you confirmed you have 12 vdc? Voltages at or below 12vdc will cause issues. Some devices rated at 12 vdc actually require 12.5vdc or more to operate correctly. One example is my roof mounted sat dish, at 12vdc it keeps booting up, shutting down and booting up loop. At 13 vdc it works fine.
__________________

__________________
John & Debbie
2008 Fleetwood Discovery 40X Full Timers Since Oct 2015
KF5UMC is offline   Reply With Quote
Reply

Tags
intellitec, ems, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay Switch (Solenoid) Problem rcote52738 Class A Motorhome Discussions 18 10-20-2011 06:31 PM
Battery switch/relay location JOE&SHARON Newmar Owner's Forum 4 02-17-2010 07:49 PM
Ignition switch/ relay wiring dmeck Workhorse and Chevrolet Chassis Motorhome Forum 11 05-01-2009 08:10 PM
Wiring relay switch location 2000 dutch star dobrien MH-General Discussions & Problems 1 05-13-2007 09:23 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.