RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-27-2014, 02:59 PM   #1
Junior Member
 
Join Date: Dec 2014
Posts: 9
Need help with power rear view mirrors on 1992 Fleetwood southwind

Don't know where to start.. Checked fuses, but don't know which switches need voltage. Any help with a diagram would help
__________________

aabernathy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-27-2014, 03:06 PM   #2
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,544
More info. would help.......fuse? both mirrors? Using a meter, check for 12v at the switch...., then if no power, locate the fuse location for the mirror's. And , Oh, I am sorry.....
__________________

__________________
2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is online now   Reply With Quote
Old 12-28-2014, 09:50 AM   #3
Junior Member
 
Join Date: Dec 2014
Posts: 9
Sorry about that, I'm not too computer saavy. My name is aaron. The rig is a 1992 Fleetwood southwind on a Ford chassis. It has power rear view mirrors on driver and passengers side. The control panel is located on the driver side armrest. I noticed the L/R selector switch had some soot on it and possibly burnt out. I replaced that DPDT switch with a new one. Now I get voltage going up to the mirror motor when I activate the "joystick" to select the mirror position. But still no movement from the motor/mirror
aabernathy is offline   Reply With Quote
Old 12-28-2014, 09:53 AM   #4
Junior Member
 
Join Date: Dec 2014
Posts: 9
If I had a schematic I might be a be able to trace every wire to ensure its routed correctly and getting the voltage where it it suppose
aabernathy is offline   Reply With Quote
Old 12-28-2014, 10:00 AM   #5
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,544
Sounds like the mirror motor failed.....
__________________
2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is online now   Reply With Quote
Old 12-28-2014, 12:46 PM   #6
Junior Member
 
Join Date: Dec 2014
Posts: 9
I'm with you on that course pale horse. It seems like it would be a lot of trouble to get to those motors and replace. Is there a breakdown I can order somewhere to tear it down or do I need to buy the complete mirror unit
aabernathy is offline   Reply With Quote
Old 12-28-2014, 12:48 PM   #7
Junior Member
 
Join Date: Dec 2014
Posts: 9
So is it common to have both mirrors fail?
aabernathy is offline   Reply With Quote
Old 12-28-2014, 01:00 PM   #8
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,544
Quote:
Originally Posted by aabernathy View Post
So is it common to have both mirrors fail?
No not common, for the age of yours, bad, corroded connections, no power, burned up motors, motors frozen up, locked in place, even though there is power to them. The list goes on and on........Troubleshooting with a meter will take you to the problem...............Good luck
I am sure that you can repair the motor drives, if they are in fact the problem.?
__________________
2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is online now   Reply With Quote
Old 12-28-2014, 01:38 PM   #9
Junior Member
 
Join Date: Dec 2014
Posts: 9
I just looked at it again. Doesn't look too bad to remove the mirror and get to the motor. I'm going to attempt to spray some QD electronic cleaner and try to free it up. On the other hand I can I can adjust the mirror manually. We will see if corrosion is the culprit. Thanks again PH89
aabernathy is offline   Reply With Quote
Old 12-28-2014, 01:48 PM   #10
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,544
Quote:
Originally Posted by aabernathy View Post
I just looked at it again. Doesn't look too bad to remove the mirror and get to the motor. I'm going to attempt to spray some QD electronic cleaner and try to free it up. On the other hand I can I can adjust the mirror manually. We will see if corrosion is the culprit. Thanks again PH89
You are very welcome! I hope you get them working.......
Again, Welcome to the forum! There is a "Wealth of Information" on here.......looking forward to your other posts and threads
__________________

__________________
2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is online now   Reply With Quote
Reply

Tags
southwind, power, fleetwood, need help



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard of my '88 Fleetwood SouthWind. KSagal Vintage RV's 1 10-22-2014 06:37 AM
Adding a second rear view camera mrt_1111 RV Systems & Appliances 3 10-01-2014 04:01 PM
Taking carpet out - 2005 Fleetwood Southwind 32V Broncos1 Fleetwood Owner's Forum 2 08-14-2014 11:27 AM
Fleetwood Revolution rear camera okiegirl2u Class A Motorhome Discussions 11 07-31-2014 06:13 PM
Rear Camera Field of View dfunde01 Entegra Owner's Forum 30 12-26-2013 09:42 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.