RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-02-2015, 12:50 PM   #1
Junior Member
 
Join Date: Mar 2015
Posts: 2
Southwind Storm

I tried to start the generator but it would not crank. I then turned on the ignition and the coach lights flashed and then went dead also the refer power went out. I then started the engine and the power to the lights and refer came back on.
__________________

ladydi014 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-04-2015, 03:29 PM   #2
Senior Member
 
Join Date: Jul 2012
Location: Southern New Jersey
Posts: 220
Sounds like either a battery issue or load on generator while trying to crank. Try unplugging the shore cord from the outlet in the electric bay, if yours connects that way, and then try cranking the generator. Make sure the oil in the geni is up to the "full" mark.
__________________

denverh is offline   Reply With Quote
Old 07-04-2015, 06:53 PM   #3
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,015
All this is battery related. Check the water level in the batteries. Then check all battery connections for corrosion and tightness.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Reply

Tags
southwind



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 or 15 Fleetwood Storm 32H? H-School Bus Fleetwood Owner's Forum 11 03-20-2015 07:23 AM
Need truck toad for older Fleetwood Southwind Storm susanka Toads and Motorhome Related Towing 10 08-23-2014 08:54 PM
Location of radiator drain plug, 1998 Southwind Storm edienick Ford Motorhome Chassis Forum 4 01-06-2014 04:57 PM
Just bought a 1997 Fleetwood Southwind Storm 30ft Btolby Class A Motorhome Discussions 13 12-16-2013 12:21 PM
'96 Southwind Storm corner129 Fleetwood Owner's Forum 1 12-15-2013 10:03 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.