RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Foretravel Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-26-2018, 11:32 AM   #1
Junior Member
 
Join Date: Feb 2016
Posts: 2
2003 Won't start

Turn key clicking noice in front dashboard
__________________

jrstables2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-26-2018, 12:40 PM   #2
Senior Member
 
Join Date: Sep 2017
Location: Full Timer - where ever we are parked
Posts: 125
Have you checked your engine and coach batteries to make sure they are fully charged? If fully charged check the battery cable connections and make sure they are clean and tightened down. Good luck.
__________________

valentob is offline   Reply With Quote
Old 12-26-2018, 04:09 PM   #3
Senior Member
 
Join Date: Jul 2017
Location: Cypress, Tx.
Posts: 201
What happens when you hit the battery boost switch?
__________________
2014 Foretravel IH45
1997 Foretravel U295 36'
Houston (Cypress), TX.
Turbojack is offline   Reply With Quote
Old 12-29-2018, 03:59 PM   #4
Senior Member
 
Join Date: Sep 2017
Location: Full Timer - where ever we are parked
Posts: 125
jrstables2 - Did you ever get your coach started? If so, what did you find the problem to be?
valentob is offline   Reply With Quote
Old 12-29-2018, 08:50 PM   #5
Junior Member
 
Join Date: Oct 2018
Posts: 22
I have had my coach do the same thing. Both batteries were a bit low so I made sure they were fully charged. Then I went to start and made sure it was for sure in Neutral (I have a diesel) I did this by clicking the button on the shifter and firm in Neutral. Started right up. Seems if you bump this at all it loosens and won't start. So simple but it worked like a charm.
KtyTravel is offline   Reply With Quote
Old 12-31-2018, 07:59 AM   #6
Junior Member
 
Join Date: Feb 2016
Posts: 2
Yes , it was a loose connection coming from the ECM 30 amp breaker on the engine bay wall. Something about no communication from the Allison transmission. (who knew) Batteries are brand new. Great mechanic at EVS in Conway ar.


They also replaced ground stud and battery cable going to it, however that did not fix the issue. the ECM breaker connection did.
jrstables2 is offline   Reply With Quote
Old 12-31-2018, 06:37 PM   #7
Senior Member
 
Join Date: Sep 2017
Location: Full Timer - where ever we are parked
Posts: 125
Thank you for the follow-up answer to your problem for now I can add that to my check list if I have a similar problem someday!
__________________
2004 Foretravel U320 3823 PBBS
2007 Newell #815 (Downsized to Foretravel)
Full Timer
valentob is offline   Reply With Quote
Old 11-11-2019, 10:58 AM   #8
Senior Member
 
darstar's Avatar
 
Join Date: Mar 2013
Location: Marquette, Mi.on the shore of Superior
Posts: 642
Quote:
Originally Posted by jrstables2 View Post
Turn key clicking noice in front dashboard
Did you ever have the starting problem again. .? I have the same problem but now gen will not start ether......first time in Texas road mechanic hot jumped something, went to Little Rock 3 new batteries at Cummins...never did find problem. Now 6 mo later as we are getting to head south, same problem, what year is your Fourtravel.? Will try to get roadservices today. Just thought I would ask,our problems sound similar....
darstar is offline   Reply With Quote
Old 11-28-2019, 09:48 PM   #9
Senior Member
 
darstar's Avatar
 
Join Date: Mar 2013
Location: Marquette, Mi.on the shore of Superior
Posts: 642
Engine start solved with nowstarter motor. Generator starts but shuts down at different run times. Fault shows high temp . ......more problems, now on the rd in Illinois ...no brakes , air pressure ,none ! Will call repair shop on I-80,la Salle tomorrow. Not so fun trip so far.......
darstar is offline   Reply With Quote
Old 11-29-2019, 04:26 PM   #10
Senior Member
 
darstar's Avatar
 
Join Date: Mar 2013
Location: Marquette, Mi.on the shore of Superior
Posts: 642
Well I have found independent local shop. ( good Sam was a rip off ) here in La Salle that came over , decided all predictions ( I paid 280.00 for yesterday ) that I needed new Air compressor, will be here Monday,. Will come over mon to air up chassis so I can drive to their shop, one mile away . ......( it paid to unload car and drive to Kittleson shop even tho they were closed for holidays. ) .....lesson learned when in trouble , you need to find all possibilities yourself, no one else will help you ).....
darstar is offline   Reply With Quote
Old 11-29-2019, 05:01 PM   #11
Senior Member
 
darstar's Avatar
 
Join Date: Mar 2013
Location: Marquette, Mi.on the shore of Superior
Posts: 642
I am looking forward to getting back on the road. It’s a real bummer to be shut down on Thanksgivings day for a total air compressor failure on my Cummins 2004 500 hp engine. Kettelemans in La Salle, Illinois has came to my rescue, when all others had no interest
In motor coaches or those whe were stranded during the holiday. Follow up is forthcoming on our returning to the big road.
darstar is offline   Reply With Quote
Old 12-05-2019, 10:35 PM   #12
Junior Member
 
Join Date: Dec 2019
Posts: 1
So did the new Compressor fix the problem?
I had a similar issue and had to rebuild my air dryer.
__________________

DEMaxfield is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 M11 Coach won't start Busnut Monaco Owner's Forum 4 06-18-2018 04:33 AM
V10 6.8L - 2003 Fleetwood Flair - won't start KevinAndRose Ford Motorhome Chassis Forum 7 10-23-2017 01:45 PM
Onan EC-30 auto start issues...won't start for HVAC CALL jstdreamin MH-General Discussions & Problems 7 05-24-2016 12:04 PM
2007 600HP ISX stalled after start, now won't start slemnah Cummins Engines 2 01-26-2015 09:06 AM
2003 Gulf Stream Sun Voyager Won't start rvcrazy Workhorse and Chevrolet Chassis Motorhome Forum 5 02-11-2009 06:27 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×