Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 12-12-2010, 11:17 PM   #1
Join Date: Oct 2010
Posts: 32
2009 Country Coach Inspire

This coach is new to me and I'm not quite sure how the lights in this coach should work ???

If I unplug from shore power and turn off the inverter in my 2009 Country Coach Inspire I can not turn on any of my interior lights ??? If I turn on the inverter or just plug into shore power the lights all work normally ???

Is this normal or should the lights work from the battery with out the invertor in the on position or a 120 volt supply from shore power ??

Thanks for any help you can offer


egb243 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-13-2010, 02:57 AM   #2
Community Moderator
RV Wizard's Avatar

Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 11,807
It sounds as though the battery disconnect solenoid is not closed or there is an open fuse or circuit breaker. You should be able to turn on the house batteries and 12 vdc circuits work without shore, generator or inverter power being turned on. Recommend you get the owners manual and check out the house (coach) battery bank disconnect wiring. Use a test light to check across fuses and circuit breakers if you cannot easily see one blown or tripped. If the over current protection devices are good then check the solenoid itself for proper operation.

Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 12-13-2010, 07:08 AM   #3
Junior Member
Join Date: Apr 2006
Posts: 22
Are you sure that the "house disconnect" switch right at the entry door is in the on position.
mattandcarol is offline   Reply With Quote
Old 12-13-2010, 10:50 AM   #4
Senior Member
Country Coach Owners Club
Join Date: Jan 2006
Location: Sacramento Area
Posts: 3,228
Country Coach, at least through the 2007 Magna, installed 2 300A Class T Fuses between the inverter and the Batteries.

Fuse, Class T, 300 A - Fuses - Fuses - Electrical : Grainger Industrial Supply

Both I (1995 Magna) and my Buddy (2007 Magna) have had similar symptoms to yours and replacing one of those fuses solved the problem. Use your volt meter to determine if one has failed.

Your wiring diagrams should indicate where they are installed, if they are present on your rig. I have one in the Battery compartment and one near the inverter.
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 12-13-2010, 03:58 PM   #5
Join Date: Oct 2010
Posts: 32
OK --
I went out and re-set the breakers in the battyery compartment and all is well now, the interior lights all work just fine off the batteries only with the inverter off and the coach unpluged from shore power.

Thanks a bunch for the suggestions -- You guys on this forum make owning a Country Coach a much better experience!!!

One more question if I can

My living room floor heat dosen't work -- there is a 20 amp 120 volt breaker in the pannel and the breaker is in the on position, The controll seems to be working fine but the floor just dosen't ever get warm ?? The bedroom floor and the rear bath are working fine, only the living room floor dosen't get warm???

Do you have any clues as to what might be unpluged or where there may be another fuse ???

egb243 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 country coach inspire with cat c9 400hp eng. any known problems? ja63 Caterpillar Engine Forum 2 12-11-2010 04:44 AM
Lee's Starting Back up Country Coach 2011 Smitty77 Country Coach Owners Forum 7 11-30-2010 08:58 PM
2004 country coach intrigue roof ja63 Country Coach Owners Forum 6 10-31-2010 09:29 AM
Country Coach Inspire Prospective Acquisition Hugh D Country Coach Owners Forum 19 01-12-2009 04:56 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:04 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.