Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-10-2012, 09:29 PM   #1
Member
 
Join Date: Oct 2011
Location: Lake Nacimiento, CA
Posts: 32
37' allure 470

We are traveling with friends who have a 2008 Country Coach Allure 470. When we arrived here in Hazelton, BC to start our 2 month trip to Alaska the back 2 slides would not open. The front 2 slides open fine.
The mechanics here have checked fuses, elec. panels, etc. There is no power to the slide switch in the hallway. Oregon Motor Coach as well as HWH (the maker of the two rear slides) have been called. There might also be a problem with the leveling system. The slides are hydraulic, as is the front passenger slide which works.
Any suggestions would be appreciated, this is about to end our trip to Alaska if it doesn't get fixed. We have been working on this for over 7 hours, help!!!
Please contact us at sydneyandjerry@gmail.com
Thank You,
Jerry
__________________

__________________
gda raiser is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-31-2012, 08:25 PM   #2
Junior Member
 
Country Coach Owners Club
Join Date: Oct 2011
Posts: 23
Not sure if this is your problem.
We had a similar problem with one of our slides. We found a large bolt broken off near the shaft that turns the rail to move the slide out. The bolt got wedged and locked everything up. Once we got the bolt out and replaced it everything worked. It was like a shear pin.
__________________

__________________
ninjalobo is offline   Reply With Quote
Old 05-31-2012, 08:52 PM   #3
Senior Member
 
B Bob's Avatar
 
Join Date: Sep 2010
Posts: 1,162
I have also used Kevin Waite and the Country Coach factory both in the Eugene area of Oregon. To find Kevin just google his name and country coach repair work in Eugene.
__________________
B Bob
Country Coach 42' Affinity
2013 Jeep Wrangler Unlimited
B Bob is offline   Reply With Quote
Old 05-31-2012, 08:54 PM   #4
Senior Member
 
B Bob's Avatar
 
Join Date: Sep 2010
Posts: 1,162
Kevin Waite is RV repair Kevin Waite 541-953-6162.
__________________
B Bob
Country Coach 42' Affinity
2013 Jeep Wrangler Unlimited
B Bob is offline   Reply With Quote
Old 10-20-2012, 09:05 AM   #5
Junior Member
 
Join Date: Aug 2012
Posts: 24
How often do you need to replace the bolt that holds the slide rails together? I just had one to fail on my 2007 Tribute and the paint on the outside wall of the slide was scratched when the slide wedged open......
__________________
Haleyjean50 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.