Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-18-2016, 04:24 PM   #1
Junior Member
 
Join Date: Feb 2016
Posts: 3
Cruise Control not working

I have a 2000 CC Allure 40' with a 330hp Cummins ISC engine. I cannot get the cruise control to work. I checked all the fuses and they are good. The cruise is also used to speed up the rpm's at idle and that part works. Just when you go down the road and turn it on and it doesn't do anything.
__________________

__________________
handymitch is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-18-2016, 04:31 PM   #2
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,383
Check the taillights.
__________________

__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 02-19-2016, 08:08 AM   #3
Junior Member
 
Join Date: Feb 2016
Posts: 3
I put all new led bulbs on the entire motorhome. All bulbs were working before I did this and I had the problem then also.

Thanks for the suggestion.
__________________
handymitch is offline   Reply With Quote
Old 02-19-2016, 08:14 AM   #4
mff
Member
 
Join Date: Sep 2012
Posts: 37
Quote:
Originally Posted by handymitch View Post
I have a 2000 CC Allure 40' with a 330hp Cummins ISC engine. I cannot get the cruise control to work. I checked all the fuses and they are good. The cruise is also used to speed up the rpm's at idle and that part works. Just when you go down the road and turn it on and it doesn't do anything.

See: Trouble shooting for cruise systems
__________________
mff is offline   Reply With Quote
Old 02-20-2016, 12:17 PM   #5
Senior Member
 
DoubleCK's Avatar
 
Join Date: Jun 2012
Location: Sheridan, Wyoming
Posts: 162
We were having problems with our Cruise Control and our Horns.

Figured our it was the switching system in the Smart Wheel. After we had that replaced, all kinds of things started working.

__________________
Craig & Karen....Tike & Tucker
'05 Country Coach.. '16 Lariat ..Honda Pioneer 500
Retired & Full-Time since September 2014!
DoubleCK is offline   Reply With Quote
Old 02-20-2016, 12:45 PM   #6
Senior Member
 
Monacoach's Avatar
 
Join Date: Oct 2010
Posts: 1,673
Put your foot under the brake pedal and pull up to ensure it is not sticking.
__________________
2008 Holiday Rambler Vacationer 340 Cummins
Monacoach is offline   Reply With Quote
Old 02-20-2016, 02:04 PM   #7
Senior Member
 
Join Date: Sep 2010
Posts: 1,896
On our 04 Essex with cruise control buttons on steering wheel found the connection to smart wheel in outside cabinet loss and pushed in tight and cruise control back working.
__________________
tom chelbana is offline   Reply With Quote
Old 02-20-2016, 10:50 PM   #8
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2011
Posts: 929
Check for recall notices for your coach. Also if you have a smart wheel make sure the ground is good. Good Luck
__________________
pumper9x9 is offline   Reply With Quote
Old 02-22-2016, 10:21 AM   #9
Junior Member
 
Join Date: Feb 2016
Posts: 3
Cruise not working

Thanks to all who responded. I will be checking the brake pedal and the trouble shooting guide out.
My mh does not have the smart wheel option.

Thanks very much,
hm
__________________
handymitch is offline   Reply With Quote
Old 02-23-2016, 10:48 AM   #10
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
Quote:
Originally Posted by handymitch View Post
I have a 2000 CC Allure 40' with a 330hp Cummins ISC engine. I cannot get the cruise control to work. I checked all the fuses and they are good. The cruise is also used to speed up the rpm's at idle and that part works. Just when you go down the road and turn it on and it doesn't do anything.
Also, try the Cruise Control with the Exhaust Brake turned off. I have heard of the CC being defeated by the Exhaust Brake on some rigs.
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 03-06-2016, 11:36 AM   #11
Senior Member
 
bobioknight's Avatar


 
Join Date: Dec 2012
Posts: 255
Cruise control trouble shooting

It's easier than you might think. Here is the steps from the owners manual

https://www.dropbox.com/s/ljvk5jkepuym20q/Cruise%20control.jpeg?dl=0
__________________

__________________
bobioknight is offline   Reply With Quote
Reply

Tags
cruise control



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control lmcintosh Monaco Owner's Forum 7 01-05-2016 08:15 PM
Check Engine Light and cruise control crkoral Class A Motorhome Discussions 11 10-26-2015 08:31 PM
CRUISE CONTROL - what gives? rerrion Sprinter Chassis Forum 4 08-27-2015 12:59 PM
No cruise control Furniss MH-General Discussions & Problems 5 08-15-2015 11:52 PM
2007 Monaco Diplomat Cruise Control Vibration ssalsman Class A Motorhome Discussions 4 02-05-2015 12:23 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.