Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-02-2014, 11:11 AM   #1
Senior Member
 
mike brez's Avatar
 
Join Date: May 2005
Location: Milford,CT.
Posts: 1,359
Electric problem with picture

While trying to find out why my electric purge valve was not working I found a bunch of fuses in the front compartment kinda under the drivers seat. I have only had this rv for a few days now so not familiar with it at all.
Seems like a whole fuse bank is out. Is there a master fuse/breaker? Hard to see but the middle section is out. Left and right sides are all lit up green.
I ran out of time today so thought I would ask here to get a jump on it tomorrow.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	51
Size:	286.9 KB
ID:	72703  
__________________

__________________
1998 36ft Country Coach Magna #5499
Gillig chassis with a Detroit series 40
2002 F250 CC 7.3 PSD
mike brez is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-02-2014, 11:23 AM   #2
RVM#87 / Senior Member
 
DieselTech39's Avatar


 
Solo Rvers Club
Join Date: Jul 2014
Location: Ham Lake, MN
Posts: 3,038
Just a thought....Do you have the ignition key turned on? If not, maybe the middle ones are controlled by turning it on? Could it be they are for the tail/stop/turn wiring? Best of luck on a solution.
__________________

__________________
Have a wonderful day!
Ken (RVM 87)
FT DP Wanna B The journey is the destination!
Retired & perfecting procrastination!
DieselTech39 is offline   Reply With Quote
Old 09-02-2014, 11:54 AM   #3
Senior Member
 
Join Date: May 2013
Location: San antonio, TX
Posts: 597
We have one column that only comes on with the ignition switch. In ours it is the right column--yours may be different.
__________________
USAF Retired
2000 Prevost Marathon H3-45
Towing 2006 Nissan Maxima
Peralko is offline   Reply With Quote
Old 09-02-2014, 01:37 PM   #4
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
We have a similar rig.

Center row on the Front Run Board only light with ignition key.
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 09-02-2014, 02:30 PM   #5
Senior Member
 
mike brez's Avatar
 
Join Date: May 2005
Location: Milford,CT.
Posts: 1,359
Quote:
Originally Posted by deandec View Post
We have a similar rig.

Center row on the Front Run Board only light with ignition key.
I think you guys are correct. I won't be able to try until tomorrow.
What engine do you have Dean?
__________________
1998 36ft Country Coach Magna #5499
Gillig chassis with a Detroit series 40
2002 F250 CC 7.3 PSD
mike brez is offline   Reply With Quote
Old 09-02-2014, 06:14 PM   #6
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
Cummins C8.3L 300hp.

I just reviewed the wiring schedule for my rig.

There appears to be 4 wires running from the switch to the purge valve.

There is wire 76 blue, connecting in the middle row of front run box fuses, which runs "from fuse to air purge relay" and 76 brown which runs "from relay to air purge switch".

So, if the fuse lights up with the ignition switch, the relay would be the next suspect.

It is in the same electrical compartment as the chassis fuses on my rig I suspect.
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 09-02-2014, 07:03 PM   #7
Senior Member
 
mike brez's Avatar
 
Join Date: May 2005
Location: Milford,CT.
Posts: 1,359
I have my fuel system apart right now so I'm not going to be able to turn the key on. Gonna try and find some parts for it tomorrow.
__________________

__________________
1998 36ft Country Coach Magna #5499
Gillig chassis with a Detroit series 40
2002 F250 CC 7.3 PSD
mike brez is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Okay ... I SOLVED THE AUTO PARK BRAKE PROBLEM! JerryPeck Workhorse and Chevrolet Chassis Motorhome Forum 144 10-03-2017 11:45 PM
Power Gear Leveling Neutral Safety Switch Problem jpbill National RV Owner's Forum 5 07-21-2014 06:07 PM
Norcold frosting problem Navy Flier RV Systems & Appliances 3 02-22-2014 09:10 AM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 07:18 AM
Winegard RT400s Toggling Problem gorgill Technology: Internet, TV, Satellite, Cell Phones, etc. 4 11-15-2013 04:38 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.