Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-16-2015, 10:58 AM   #1
Senior Member
 
nkgunner's Avatar


 
Join Date: Apr 2012
Location: Douglas MA
Posts: 156
Engine would not turn over...

after sitting for a couple of months. The CC was plugged into shore power the whole time. I thought the batteries for the engine would also be charging as the house batteries do. I Hooked up a battery charge for 10 minutes and she fired right up..Any thoughts?

2005 Country Coach Allure
ISL 400
__________________

__________________
nkgunner is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-16-2015, 12:07 PM   #2
Senior Member
 
Join Date: Aug 2011
Posts: 114
Quote:
Originally Posted by nkgunner View Post
after sitting for a couple of months. The CC was plugged into shore power the whole time. I thought the batteries for the engine would also be charging as the house batteries do. I Hooked up a battery charge for 10 minutes and she fired right up..Any thoughts?

2005 Country Coach Allure
ISL 400
Gunner,

I suspect your echo charger has failed. Not unusual. If this is the case I recommend you trash the Xantrex product and replace it with a the Magnum Battery Combiner. Much better at doing it's job. Mine is located in with the chassis battery up high, not easy to see. I know others can be found in different locations.

Magnum Energy ME-SBC Smart Battery Combiner Compatible with 12V or 24V Systems
__________________

__________________
Barney
07 Inspire 52059
BarneyM is offline   Reply With Quote
Old 08-16-2015, 12:22 PM   #3
Senior Member
 
macantic's Avatar
 
Join Date: Feb 2012
Location: Aiken,SC
Posts: 1,025
if you don't store it under a shelter try a solar charger.
__________________
Good Sam Life Members
Served in U.S.A.F.
macantic is offline   Reply With Quote
Old 08-16-2015, 12:45 PM   #4
Senior Member
 
nkgunner's Avatar


 
Join Date: Apr 2012
Location: Douglas MA
Posts: 156
Hi folks,
After reading many post about the same problem I am having, I decided to buy a Magnum Battery Combiner and not mess around..

How tough is it to install? Any pointers?

I checked with Magnum Energys web site and they have no mention of this product. Are they still surpporting it?

Thanks for the answers, have a great day!
__________________
nkgunner is online now   Reply With Quote
Old 08-16-2015, 05:47 PM   #5
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 1,720
I got mine here Magnum Me SBC Smart Battery Combiner 25A Combines 2 Battery Banks for Charging | eBay
and wired it up in my shop using #12 blue wire and put a strip on the starter wire with felt pen. I moved mine to a spot where I can see it when I open the battery door.
I used the same water tight fuse holder from the old one.
This is what you are looking for.
http://www.amazon.com/Xantrex-82-012...x+echo+charger
On mine
Connect 13.3V
Low V 12.9
High V 14.3
Then I placed a volt meter in the power port on the dash, can check the chassis batter by looking in the front door
http://www.amazon.com/Prime-Products...rds=volt+meter
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Old 08-17-2015, 02:55 PM   #6
Junior Member
 
gpete1961's Avatar
 
Join Date: May 2014
Location: United States
Posts: 28
I had the same problem as you last winter. I did as 2stroker recommended on my 2007 Inspire and it now works fine.
__________________
Greg and Lola the Rescue Mutt
2007 Country Coach Inspire/2014 Honda CRV
gpete1961 is offline   Reply With Quote
Old 08-22-2015, 06:17 PM   #7
Senior Member
 
nkgunner's Avatar


 
Join Date: Apr 2012
Location: Douglas MA
Posts: 156
I ordered the Magnum Me SBC Smart Battery Combiner 25A Combines 2 Battery Banks for Charging and am waiting for it to arrive. Looks like it will be an easy install.

Thanks all!
__________________
nkgunner is online now   Reply With Quote
Old 08-28-2015, 12:14 PM   #8
Senior Member
 
nkgunner's Avatar


 
Join Date: Apr 2012
Location: Douglas MA
Posts: 156
Installed the Magnum today..

unplugged from shore power and removed the other charging unit. Connected the 3 wires and checked the fuses..All looks good..hit the reset and the Green Status light goes on but a few seconds later the "Disconnect" yellow comes on..Having lunch but will check later today. The meter arrived today so I will plug that in..

Note: I set it up as 2Stroker mentioned;
Connect 13.3V
Low V 12.9
High V 14.3
__________________
nkgunner is online now   Reply With Quote
Old 08-28-2015, 05:54 PM   #9
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,816
Some RV's charge both batteries off Shore, Some house and if a fuse or breaker is blown;/tripped Neither. (or if the converter is unplugged (In at least my case not all can be) or ... defective.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 08-28-2015, 06:05 PM   #10
Senior Member
 
FunGus's Avatar
 
Monaco Owners Club
Join Date: Jun 2015
Posts: 369
On my 99 Country Coach I never knew there was a problem, but I did notice that the starting battery didn't charge from shore power, so I just hooked a pair of jumper cables from the house batteries to the starting battery when stored for any amount of time. Worked fine and never had any problems with my $15 jumper cable fix.
__________________
Loving the Beaver!
Jason, Sherri, Christian, & Wheeler (Golden Retriever)
2008 Beaver Contessa Huntington CAT C9 400hp FMCA F25478 S4
FunGus is offline   Reply With Quote
Old 08-30-2015, 10:16 PM   #11
Senior Member
 
dons2346's Avatar
 
Country Coach Owners Club
Join Date: Dec 2010
Posts: 4,487
Quote:
Originally Posted by nkgunner View Post
unplugged from shore power and removed the other charging unit. Connected the 3 wires and checked the fuses..All looks good..hit the reset and the Green Status light goes on but a few seconds later the "Disconnect" yellow comes on..Having lunch but will check later today. The meter arrived today so I will plug that in..

Note: I set it up as 2Stroker mentioned;
Connect 13.3V
Low V 12.9
High V 14.3
It could be that your chassis battery is so discharged, the combiner won't work. I would use an external charger to bring the chassis battery up to 12.7 (at rest) and then see what happens. It could be that your battery is toast.
__________________
Don
2002 Country Coach Intrigue
dons2346 is offline   Reply With Quote
Old 08-31-2015, 12:56 PM   #12
Senior Member
 
Join Date: Aug 2011
Posts: 114
Quote:
Originally Posted by nkgunner View Post
unplugged from shore power and removed the other charging unit. Connected the 3 wires and checked the fuses..All looks good..hit the reset and the Green Status light goes on but a few seconds later the "Disconnect" yellow comes on..Having lunch but will check later today. The meter arrived today so I will plug that in..

Note: I set it up as 2Stroker mentioned;
Connect 13.3V
Low V 12.9
High V 14.3
Gunner,

What you are looking for is that your chassis battery is being charged the same time your house batterers are. So when you disconnect the charger the voltage in the house batteries will drop fairly quickly below the 5.9v setting and the battery combiner will disconnect to make sure the chassis battery does not discharge the house batteries. It is normal for the yellow light be to be on when you are NOT connected to shore power. The green light should be on whenever you are connected to shore power and the charger is operating.
__________________
Barney
07 Inspire 52059
BarneyM is offline   Reply With Quote
Old 08-31-2015, 03:56 PM   #13
Senior Member
 
Rsponsford's Avatar


 
Country Coach Owners Club
Join Date: Aug 2015
Location: Santa Rosa, CA
Posts: 375
Quote:
Originally Posted by nkgunner View Post
after sitting for a couple of months. The CC was plugged into shore power the whole time. I thought the batteries for the engine would also be charging as the house batteries do. I Hooked up a battery charge for 10 minutes and she fired right up..Any thoughts?

2005 Country Coach Allure
ISL 400
My coach is older than yours ('90 CC Concept) and likely a different configuration but I am certain that my chassis batteries are not being charged when plugged into shore power. They only get charged when either the engine is running or if I use the continuous "Boost" switch to jump start the chassis batteries off the running generator.

I recently had to replace this boost relay solenoid. It failed and welded itself shut and the chassis battery drained down as a result of being grounded out. I also have a separate momentary boost switch to jumpstart the generator from the chassis batteries if needed. In any case, my chassis batteries are not connected to my house batteries in any manner. Hope this helps.
__________________

__________________

Russ
1990 Country Coach Concept 36' Anteres
1997 Jeep Wrangler, Blue Ox
Rsponsford is offline   Reply With Quote
Reply

Tags
engine



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Trailer Brake or Turn Signals Eusefull Travel Supreme Owner's Forum 6 07-03-2015 03:56 PM
Wrong engine jth camper Class A Motorhome Discussions 35 06-30-2015 06:15 PM
Check Engine light adonh Caterpillar Engine Forum 25 06-28-2014 11:03 AM
The Doggone Yellow Check Engine Light (C.E.L.) troth Winnebago Industries Owner's Forum 1 05-06-2014 10:05 AM
What kind of engine brake do I have? Statgeek Freightliner Motorhome Chassis Forum 13 12-19-2013 04:47 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.