Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Country Coach Owners Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 09-19-2016, 08:23 PM   #1
Join Date: Aug 2015
Posts: 32
Front TV (Sharp) not working

I just bought a 2008 Inspire with 3 TV's. Kitchen and bedroom work fine, but the front does not even turn on. Remote had bad, corroded batteries in it...cleaned and replaced batteries. Button on top of the TV does not turn it on either. Fuses look good...mystified. Before I start taking apart the cabinet, any suggestions?

Gary Ostberg
2008 Inspire 360 36'
Lincoln MKX Toad
gostberg is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-19-2016, 08:25 PM   #2
Senior Member
mrt_1111's Avatar

Fleetwood Owners Club
Ford Super Duty Owner
iRV2 No Limits Club
Join Date: Oct 2012
Location: Colorado Springs, CO
Posts: 704
Check power with meter.

Mark Taylor
1999 Bounder 32H Ford V10, 2012 Ford Focus, Pretty DW, 2 cats. Retired USAF
mrt_1111 is online now   Reply With Quote
Old 09-20-2016, 07:22 AM   #3
Join Date: Aug 2015
Posts: 32
Yea, got to pull the cabinet apart to do that...but might have to soon.
Gary Ostberg
2008 Inspire 360 36'
Lincoln MKX Toad
gostberg is offline   Reply With Quote
Old 09-20-2016, 10:33 AM   #4
Senior Member
IASM's Avatar
Join Date: Nov 2013
Posts: 383
Not sure on an 08 but there is a relay to shut off power while the rig is going down the road that may be bad. On older units the fuse was in the front left bay. If you pull the fuse it will verify the relay is closed.
IASM is offline   Reply With Quote
Old 09-20-2016, 12:47 PM   #5
Moderator Emeritus
smlranger's Avatar

Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 6,355
Blog Entries: 1
Yes, do check your ignition interlock device. You can reach it and the plug from the TV by removing the side panel in the compartment to the right of the TV.

I had a 37" Sharp in my 07 that did the same thing 2 years ago. It just would not come on one day. I unplugged it from the interlock and plugged it into another power outlet. No go. It was just dead.

Replaced it with a 40" Samsung. The Samsung is much lighter than the Sharp. Filled the gap at the bottom with a sound bar.
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide not working / motor is working chrisc8869 5th Wheel Discussion 5 08-15-2015 06:24 PM
Sharp R-1850 Convection Oven not Hot Enough jbenalpine Alpine Coach Owner's Forum 3 07-16-2015 08:15 PM
Front air and front gfi plug stopped working? bigdomino Monaco Owner's Forum 4 01-27-2012 09:43 AM
Sharp Micro not working......again C&C R Winnebago Industries Owner's Forum 2 09-27-2009 06:42 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.